aboutsummaryrefslogtreecommitdiff
path: root/security/openssl-beta
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-07-30 17:38:18 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-07-30 17:38:18 +0000
commit6beb927cded51c0626956ccee35f1a12534f4e71 (patch)
treea39cba2cd15d771bd279b7075ab405ed4fcc5c23 /security/openssl-beta
parent1e3798994451799b36a6b674cddaac229059d2af (diff)
downloadports-6beb927cded51c0626956ccee35f1a12534f4e71.tar.gz
ports-6beb927cded51c0626956ccee35f1a12534f4e71.zip
Security Update to 0.9.6e
Notes
Notes: svn path=/head/; revision=63747
Diffstat (limited to 'security/openssl-beta')
-rw-r--r--security/openssl-beta/Makefile9
-rw-r--r--security/openssl-beta/distinfo2
-rw-r--r--security/openssl-beta/files/patch-ah53
3 files changed, 6 insertions, 58 deletions
diff --git a/security/openssl-beta/Makefile b/security/openssl-beta/Makefile
index c839007b1ed0..b067b249a2cc 100644
--- a/security/openssl-beta/Makefile
+++ b/security/openssl-beta/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openssl
-PORTVERSION= 0.9.6d
+PORTVERSION= 0.9.6e
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@@ -99,9 +99,10 @@ MAN3= BN_CTX_new.3 BN_CTX_start.3 BN_add.3 BN_add_word.3 \
SSL_SESSION_get_ex_new_index.3 SSL_SESSION_get_time.3 \
SSL_accept.3 SSL_alert_type_string.3 SSL_clear.3 \
SSL_connect.3 SSL_free.3 SSL_get_SSL_CTX.3 SSL_get_ciphers.3 \
- SSL_get_client_CA_list.3 SSL_get_current_cipher.3 \
- SSL_get_default_timeout.3 SSL_get_ex_data_X509_STORE_CTX_idx.3 \
- SSL_get_ex_new_index.3 SSL_get_fd.3 SSL_get_peer_cert_chain.3 \
+ SSL_do_handshake.3 SSL_get_client_CA_list.3 \
+ SSL_get_current_cipher.3 SSL_get_default_timeout.3 \
+ SSL_get_ex_data_X509_STORE_CTX_idx.3 SSL_get_ex_new_index.3 \
+ SSL_get_fd.3 SSL_get_peer_cert_chain.3 \
SSL_get_peer_certificate.3 SSL_get_rbio.3 SSL_get_session.3 \
SSL_get_verify_result.3 SSL_get_version.3 SSL_library_init.3 \
SSL_load_client_CA_file.3 SSL_new.3 SSL_pending.3 SSL_read.3 \
diff --git a/security/openssl-beta/distinfo b/security/openssl-beta/distinfo
index cdd7f2e47220..def0e535b40f 100644
--- a/security/openssl-beta/distinfo
+++ b/security/openssl-beta/distinfo
@@ -1 +1 @@
-MD5 (openssl-0.9.6d.tar.gz) = 6cba586958f6e35f28dde70bd9e5d10a
+MD5 (openssl-0.9.6e.tar.gz) = 2f57a28e6a2468c488d49bb4dd31f24a
diff --git a/security/openssl-beta/files/patch-ah b/security/openssl-beta/files/patch-ah
deleted file mode 100644
index 7ca781180b32..000000000000
--- a/security/openssl-beta/files/patch-ah
+++ /dev/null
@@ -1,53 +0,0 @@
---- config.orig Tue Mar 14 00:52:44 2000
-+++ config Sat Apr 15 14:18:03 2000
-@@ -311,50 +311,6 @@
- esac
- done
-
--# figure out if gcc is available and if so we use it otherwise
--# we fallback to whatever cc does on the system
--GCCVER=`(gcc --version) 2>/dev/null`
--if [ "$GCCVER" != "" ]; then
-- CC=gcc
-- # then strip off whatever prefix Cygnus prepends the number with...
-- GCCVER=`echo $GCCVER | sed 's/^[a-z]*\-//'`
-- # peak single digit before and after first dot, e.g. 2.95.1 gives 29
-- GCCVER=`echo $GCCVER | sed 's/\([0-9]\)\.\([0-9]\).*/\1\2/'`
--else
-- CC=cc
--fi
--
--if [ "$SYSTEM" = "SunOS" ]; then
-- # check for WorkShop C, expected output is "cc: blah-blah C x.x"
-- CCVER=`(cc -V 2>&1) 2>/dev/null | \
-- egrep -e '^cc: .* C [0-9]\.[0-9]' | \
-- sed 's/.* C \([0-9]\)\.\([0-9]\).*/\1\2/'`
-- CCVER=${CCVER:-0}
-- if [ $CCVER -gt 40 ]; then
-- CC=cc # overrides gcc!!!
-- if [ $CCVER -eq 50 ]; then
-- echo "WARNING! Detected WorkShop C 5.0. Do make sure you have"
-- echo " patch #107357-01 or later applied."
-- sleep 5
-- fi
-- elif [ "$CC" = "cc" -a $CCVER -gt 0 ]; then
-- CC=sc3
-- fi
--fi
--
--if [ "${SYSTEM}-${MACHINE}" = "Linux-alpha" ]; then
-- # check for Compaq C, expected output is "blah-blah C Vx.x"
-- CCCVER=`(ccc -V 2>&1) 2>/dev/null | \
-- egrep -e '.* C V[0-9]\.[0-9]' | \
-- sed 's/.* C V\([0-9]\)\.\([0-9]\).*/\1\2/'`
-- CCCVER=${CCCVER:-0}
-- if [ $CCCVER -gt 60 ]; then
-- CC=ccc # overrides gcc!!! well, ccc outperforms inoticeably
-- # only on hash routines and des, otherwise gcc (2.95)
-- # keeps along rather tight...
-- fi
--fi
--
- GCCVER=${GCCVER:-0}
- CCVER=${CCVER:-0}
-