aboutsummaryrefslogtreecommitdiff
path: root/security/openssl111
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2019-03-07 19:56:40 +0000
committerBernard Spil <brnrd@FreeBSD.org>2019-03-07 19:56:40 +0000
commite792d3a8bcffcdef674bc9ee2e224327e23787d7 (patch)
tree54aa3d4ecaba3036c8c2d025c62779b394e41da5 /security/openssl111
parent5ae2d16bd1a895b1c3e1ba9ba0ef5881863639ee (diff)
downloadports-e792d3a8bcffcdef674bc9ee2e224327e23787d7.tar.gz
ports-e792d3a8bcffcdef674bc9ee2e224327e23787d7.zip
security/openssl111: Security update for CVE-2019-1543
MFH: 2019Q1 Security: e56f2f7c-410e-11e9-b95c-b499baebfeaf
Notes
Notes: svn path=/head/; revision=494996
Diffstat (limited to 'security/openssl111')
-rw-r--r--security/openssl111/Makefile2
-rw-r--r--security/openssl111/files/patch-CVE-2019-154366
2 files changed, 67 insertions, 1 deletions
diff --git a/security/openssl111/Makefile b/security/openssl111/Makefile
index 6a3a33d9ab03..8ce33ea1ffcd 100644
--- a/security/openssl111/Makefile
+++ b/security/openssl111/Makefile
@@ -3,6 +3,7 @@
PORTNAME= openssl
PORTVERSION= 1.1.1b
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= https://www.openssl.org/source/ \
ftp://ftp.cert.dfn.de/pub/tools/net/openssl/source/
@@ -29,7 +30,6 @@ USE_PERL5= build
TEST_TARGET= test
LDFLAGS_i386= -Wl,-znotext
-#LDFLAGS= ${LDFLAGS_${ARCH}}
MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive CNF_LDFLAGS="${LDFLAGS}"
MAKE_ENV+= LIBRPATH="${PREFIX}/lib" GREP_OPTIONS=
diff --git a/security/openssl111/files/patch-CVE-2019-1543 b/security/openssl111/files/patch-CVE-2019-1543
new file mode 100644
index 000000000000..243ec34a55ad
--- /dev/null
+++ b/security/openssl111/files/patch-CVE-2019-1543
@@ -0,0 +1,66 @@
+From f426625b6ae9a7831010750490a5f0ad689c5ba3 Mon Sep 17 00:00:00 2001
+From: Matt Caswell <matt@openssl.org>
+Date: Tue, 5 Mar 2019 14:39:15 +0000
+Subject: [PATCH] Prevent over long nonces in ChaCha20-Poly1305
+
+ChaCha20-Poly1305 is an AEAD cipher, and requires a unique nonce input for
+every encryption operation. RFC 7539 specifies that the nonce value (IV)
+should be 96 bits (12 bytes). OpenSSL allows a variable nonce length and
+front pads the nonce with 0 bytes if it is less than 12 bytes. However it
+also incorrectly allows a nonce to be set of up to 16 bytes. In this case
+only the last 12 bytes are significant and any additional leading bytes are
+ignored.
+
+It is a requirement of using this cipher that nonce values are unique.
+Messages encrypted using a reused nonce value are susceptible to serious
+confidentiality and integrity attacks. If an application changes the
+default nonce length to be longer than 12 bytes and then makes a change to
+the leading bytes of the nonce expecting the new value to be a new unique
+nonce then such an application could inadvertently encrypt messages with a
+reused nonce.
+
+Additionally the ignored bytes in a long nonce are not covered by the
+integrity guarantee of this cipher. Any application that relies on the
+integrity of these ignored leading bytes of a long nonce may be further
+affected.
+
+Any OpenSSL internal use of this cipher, including in SSL/TLS, is safe
+because no such use sets such a long nonce value. However user
+applications that use this cipher directly and set a non-default nonce
+length to be longer than 12 bytes may be vulnerable.
+
+CVE-2019-1543
+
+Fixes #8345
+
+Reviewed-by: Paul Dale <paul.dale@oracle.com>
+Reviewed-by: Richard Levitte <levitte@openssl.org>
+(Merged from https://github.com/openssl/openssl/pull/8406)
+
+(cherry picked from commit 2a3d0ee9d59156c48973592331404471aca886d6)
+---
+ crypto/evp/e_chacha20_poly1305.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/crypto/evp/e_chacha20_poly1305.c b/crypto/evp/e_chacha20_poly1305.c
+index c1917bb86a6..d3e2c622a1b 100644
+--- crypto/evp/e_chacha20_poly1305.c.orig
++++ crypto/evp/e_chacha20_poly1305.c
+@@ -30,6 +30,8 @@ typedef struct {
+
+ #define data(ctx) ((EVP_CHACHA_KEY *)(ctx)->cipher_data)
+
++#define CHACHA20_POLY1305_MAX_IVLEN 12
++
+ static int chacha_init_key(EVP_CIPHER_CTX *ctx,
+ const unsigned char user_key[CHACHA_KEY_SIZE],
+ const unsigned char iv[CHACHA_CTR_SIZE], int enc)
+@@ -533,7 +535,7 @@ static int chacha20_poly1305_ctrl(EVP_CIPHER_CTX *ctx, int type, int arg,
+ return 1;
+
+ case EVP_CTRL_AEAD_SET_IVLEN:
+- if (arg <= 0 || arg > CHACHA_CTR_SIZE)
++ if (arg <= 0 || arg > CHACHA20_POLY1305_MAX_IVLEN)
+ return 0;
+ actx->nonce_len = arg;
+ return 1;