aboutsummaryrefslogtreecommitdiff
path: root/security/openssl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-03-17 13:51:00 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-03-17 13:51:00 +0000
commit130313c7d4007ffb303bcdc3bc6c7c41fc10e006 (patch)
treee1d8b0b71c36eedcc4bbe73128923d3b2ed08cf3 /security/openssl
parent202756df9accc65cbf4c9658b89798d8d16e421f (diff)
downloadports-130313c7d4007ffb303bcdc3bc6c7c41fc10e006.tar.gz
ports-130313c7d4007ffb303bcdc3bc6c7c41fc10e006.zip
- Security update to 0.9.7d
Notes
Notes: svn path=/head/; revision=104290
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile15
-rw-r--r--security/openssl/distinfo4
-rw-r--r--security/openssl/files/patch-ag11
-rw-r--r--security/openssl/files/patch-apps-dgst.c11
-rw-r--r--security/openssl/files/patch-doc-crypto-EVP_BytesToKey.pod11
-rw-r--r--security/openssl/files/patch-doc-crypto-EVP_DigestInit.pod11
-rw-r--r--security/openssl/files/patch-doc-crypto-ui.pod11
7 files changed, 23 insertions, 51 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index b502e22bab66..5c678ecf9122 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openssl
-PORTVERSION= 0.9.7c
+PORTVERSION= 0.9.7d
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/source/ \
ftp://ftp.openssl.org/source/ \
@@ -29,9 +29,9 @@ CFLAGS+= -Wl,-rpath,${LOCALBASE}/lib
MAN1= CA.pl.1 asn1parse.1 ca.1 ciphers.1 crl.1 crl2pkcs7.1 dgst.1 dhparam.1 \
dsa.1 dsaparam.1 enc.1 gendsa.1 genrsa.1 nseq.1 ocsp.1 openssl.1 \
- passwd.1 pkcs12.1 pkcs7.1 pkcs8.1 rand.1 req.1 rsa.1 s_client.1 \
- s_server.1 sess_id.1 smime.1 speed.1 spkac.1 verify.1 version.1 \
- x509.1 rsautl.1
+ passwd.1 pkcs12.1 pkcs7.1 pkcs8.1 rand.1 req.1 rsa.1 rsautl.1 \
+ s_client.1 s_server.1 s_time.1 sess_id.1 smime.1 speed.1 spkac.1 verify.1 \
+ version.1 x509.1
MAN3= ASN1_OBJECT_new.3 ASN1_STRING_length.3 ASN1_STRING_new.3 \
ASN1_STRING_print_ex.3 BIO_ctrl.3 BIO_f_base64.3 BIO_f_buffer.3 \
@@ -43,6 +43,7 @@ MAN3= ASN1_OBJECT_new.3 ASN1_STRING_length.3 ASN1_STRING_new.3 \
BN_cmp.3 BN_copy.3 BN_generate_prime.3 BN_mod_inverse.3 \
BN_mod_mul_montgomery.3 BN_mod_mul_reciprocal.3 BN_new.3 \
BN_num_bytes.3 BN_rand.3 BN_set_bit.3 BN_swap.3 BN_zero.3 \
+ CONF_modules_free.3 CONF_modules_load_file.3 \
CRYPTO_set_ex_data.3 DH_generate_key.3 DH_generate_parameters.3 \
DH_get_ex_new_index.3 DH_new.3 DH_set_method.3 DH_size.3 \
DSA_SIG_new.3 DSA_do_sign.3 DSA_dup_DH.3 DSA_generate_key.3 \
@@ -53,7 +54,8 @@ MAN3= ASN1_OBJECT_new.3 ASN1_STRING_length.3 ASN1_STRING_new.3 \
ERR_put_error.3 ERR_remove_state.3 EVP_BytesToKey.3 EVP_DigestInit.3 \
EVP_EncryptInit.3 EVP_OpenInit.3 EVP_PKEY_new.3 EVP_PKEY_set1_RSA.3 \
EVP_SealInit.3 EVP_SignInit.3 EVP_VerifyInit.3 OBJ_nid2obj.3 \
- OPENSSL_VERSION_NUMBER.3 OpenSSL_add_all_algorithms.3 PKCS12_create.3 \
+ OPENSSL_VERSION_NUMBER.3 OpenSSL_add_all_algorithms.3 \
+ OPENSSL_config.3 OPENSSL_load_builtin_modules.3 PKCS12_create.3 \
PKCS12_parse.3 PKCS7_sign.3 PKCS7_verify.3 PKCS7_encrypt.3 \
PKCS7_decrypt.3 RAND_add.3 RAND_bytes.3 RAND_cleanup.3 RAND_egd.3 \
RAND_load_file.3 RAND_set_rand_method.3 RSA_blinding_on.3 \
@@ -285,6 +287,8 @@ MLINKS= dgst.1 md4.1 \
BN_zero.3 BN_one.3 \
BN_zero.3 BN_set_word.3 \
BN_zero.3 BN_value_one.3 \
+ CONF_modules_free.3 CONF_modules_unload.3 \
+ CONF_modules_load_file.3 CONF_modules_load.3 \
CRYPTO_set_ex_data.3 CRYPTO_get_ex_data.3 \
DH_generate_key.3 DH_compute_key.3 \
DH_generate_parameters.3 DH_check.3 \
@@ -434,6 +438,7 @@ MLINKS= dgst.1 md4.1 \
OPENSSL_VERSION_NUMBER.3 SSLeay_version.3 \
OpenSSL_add_all_algorithms.3 OpenSSL_add_all_ciphers.3 \
OpenSSL_add_all_algorithms.3 OpenSSL_add_all_digests.3 \
+ OPENSSL_config.3 OPENSSL_no_config.3 \
RAND_add.3 RAND_event.3 \
RAND_add.3 RAND_screen.3 \
RAND_add.3 RAND_seed.3 \
diff --git a/security/openssl/distinfo b/security/openssl/distinfo
index c57ee9bedafe..aeac780cbb33 100644
--- a/security/openssl/distinfo
+++ b/security/openssl/distinfo
@@ -1,2 +1,2 @@
-MD5 (openssl-0.9.7c.tar.gz) = c54fb36218adaaaba01ef733cd88c8ec
-SIZE (openssl-0.9.7c.tar.gz) = 2791797
+MD5 (openssl-0.9.7d.tar.gz) = 1b49e90fc8a75c3a507c0a624529aca5
+SIZE (openssl-0.9.7d.tar.gz) = 2798433
diff --git a/security/openssl/files/patch-ag b/security/openssl/files/patch-ag
deleted file mode 100644
index b768d1ec5012..000000000000
--- a/security/openssl/files/patch-ag
+++ /dev/null
@@ -1,11 +0,0 @@
---- apps/dgst.c.orig Tue Jun 11 13:41:17 2002
-+++ apps/dgst.c Sat Aug 10 14:40:26 2002
-@@ -340,7 +340,7 @@
- if(!out_bin)
- {
- tmp=tofree=OPENSSL_malloc(strlen(name)+strlen(argv[i])+5);
-- sprintf(tmp,"%s(%s)= ",name,argv[i]);
-+ sprintf(tmp,"%s(%s) = ",name,argv[i]);
- }
- else
- tmp="";
diff --git a/security/openssl/files/patch-apps-dgst.c b/security/openssl/files/patch-apps-dgst.c
new file mode 100644
index 000000000000..25fbf96d2c7f
--- /dev/null
+++ b/security/openssl/files/patch-apps-dgst.c
@@ -0,0 +1,11 @@
+--- apps/dgst.c.orig Sat Dec 27 15:40:56 2003
++++ apps/dgst.c Wed Mar 17 13:59:05 2004
+@@ -349,7 +349,7 @@
+ {
+ size_t len = strlen(name)+strlen(argv[i])+5;
+ tmp=tofree=OPENSSL_malloc(len);
+- BIO_snprintf(tmp,len,"%s(%s)= ",name,argv[i]);
++ BIO_snprintf(tmp,len,"%s(%s) = ",name,argv[i]);
+ }
+ else
+ tmp="";
diff --git a/security/openssl/files/patch-doc-crypto-EVP_BytesToKey.pod b/security/openssl/files/patch-doc-crypto-EVP_BytesToKey.pod
deleted file mode 100644
index f534dc2b6478..000000000000
--- a/security/openssl/files/patch-doc-crypto-EVP_BytesToKey.pod
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/crypto/EVP_BytesToKey.pod.orig Mon Dec 3 04:07:37 2001
-+++ doc/crypto/EVP_BytesToKey.pod Tue Sep 30 18:55:24 2003
-@@ -2,7 +2,7 @@
-
- =head1 NAME
-
-- EVP_BytesToKey - password based encryption routine
-+EVP_BytesToKey - password based encryption routine
-
- =head1 SYNOPSIS
-
diff --git a/security/openssl/files/patch-doc-crypto-EVP_DigestInit.pod b/security/openssl/files/patch-doc-crypto-EVP_DigestInit.pod
deleted file mode 100644
index 1a7f256c8410..000000000000
--- a/security/openssl/files/patch-doc-crypto-EVP_DigestInit.pod
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/crypto/EVP_DigestInit.pod.orig Thu Jul 18 20:55:04 2002
-+++ doc/crypto/EVP_DigestInit.pod Tue Sep 30 18:57:18 2003
-@@ -4,7 +4,7 @@
-
- EVP_MD_CTX_init, EVP_MD_CTX_create, EVP_DigestInit_ex, EVP_DigestUpdate,
- EVP_DigestFinal_ex, EVP_MD_CTX_cleanup, EVP_MD_CTX_destroy, EVP_MAX_MD_SIZE,
--EVP_MD_CTX_copy_ex EVP_MD_CTX_copy, EVP_MD_type, EVP_MD_pkey_type, EVP_MD_size,
-+EVP_MD_CTX_copy_ex, EVP_MD_CTX_copy, EVP_MD_type, EVP_MD_pkey_type, EVP_MD_size,
- EVP_MD_block_size, EVP_MD_CTX_md, EVP_MD_CTX_size, EVP_MD_CTX_block_size, EVP_MD_CTX_type,
- EVP_md_null, EVP_md2, EVP_md5, EVP_sha, EVP_sha1, EVP_dss, EVP_dss1, EVP_mdc2,
- EVP_ripemd160, EVP_get_digestbyname, EVP_get_digestbynid, EVP_get_digestbyobj -
diff --git a/security/openssl/files/patch-doc-crypto-ui.pod b/security/openssl/files/patch-doc-crypto-ui.pod
deleted file mode 100644
index fad6e3693ecf..000000000000
--- a/security/openssl/files/patch-doc-crypto-ui.pod
+++ /dev/null
@@ -1,11 +0,0 @@
---- doc/crypto/ui.pod.orig Thu Oct 25 18:55:17 2001
-+++ doc/crypto/ui.pod Tue Sep 30 18:59:45 2003
-@@ -5,7 +5,7 @@
- UI_new, UI_new_method, UI_free, UI_add_input_string, UI_dup_input_string,
- UI_add_verify_string, UI_dup_verify_string, UI_add_input_boolean,
- UI_dup_input_boolean, UI_add_info_string, UI_dup_info_string,
--UI_add_error_string, UI_dup_error_string, UI_construct_prompt
-+UI_add_error_string, UI_dup_error_string, UI_construct_prompt,
- UI_add_user_data, UI_get0_user_data, UI_get0_result, UI_process,
- UI_ctrl, UI_set_default_method, UI_get_default_method, UI_get_method,
- UI_set_method, UI_OpenSSL, ERR_load_UI_strings - New User Interface