aboutsummaryrefslogtreecommitdiff
path: root/security/openssl
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-04-05 18:21:07 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-04-05 18:21:07 +0000
commit8fedce2dc9c58b223a85fabeb13e24e5f3c653fd (patch)
tree35b289e93382f6b1ccdd5b01936ec4b0c4f4a934 /security/openssl
parent27aaf9019000f2a769f344783daf7f44e1881560 (diff)
downloadports-8fedce2dc9c58b223a85fabeb13e24e5f3c653fd.tar.gz
ports-8fedce2dc9c58b223a85fabeb13e24e5f3c653fd.zip
- add options WITH_MD2
Suggested by: Tatsuki Makino - add options WITH_RC5 and WITH_RFC3779
Notes
Notes: svn path=/head/; revision=252255
Diffstat (limited to 'security/openssl')
-rw-r--r--security/openssl/Makefile36
-rw-r--r--security/openssl/pkg-plist2
2 files changed, 36 insertions, 2 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 29f15019d0bf..5e4113c11286 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -29,6 +29,9 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
OPTIONS= I386 "Use optimized assembler for 80386" off \
SSE2 "Use runtime SSE2 detection" on \
ZLIB "Build with zlib compression" on \
+ MD2 "Build with MD2 hash (obsolete)" off \
+ RC5 "Build with RC5 chipher (patented)" off \
+ RFC3779 "Build with RFC3779 support" off \
DTLS_RENEGOTIATION "Build with DTLS Abbr. renegotiations" off \
DTLS_HEARTBEAT "Build with DTLS Heartbeat Extension" off \
TLS_EXTRACTOR "Build with TLS key material extractor" off \
@@ -1061,9 +1064,38 @@ USE_LDCONFIG= yes
.endif
.if !defined(WITHOUT_ZLIB)
-EXTRACONFIGURE+= zlib
+EXTRACONFIGURE+= zlib zlib-dynamic
.else
-EXTRACONFIGURE+= no-zlib
+EXTRACONFIGURE+= no-zlib no-zlib-dynamic
+.endif
+
+.if defined(WITH_MD2)
+EXTRACONFIGURE+= enable-md2
+PLIST_SUB+= WITH_MD2=""
+.else
+EXTRACONFIGURE+= no-md2
+PLIST_SUB+= WITH_MD2="@comment "
+.endif
+
+.if defined(WITH_RC5)
+EXTRACONFIGURE+= enable-rc5
+PLIST_SUB+= WITH_RC5=""
+.else
+EXTRACONFIGURE+= no-rc5
+PLIST_SUB+= WITH_RC5="@comment "
+.endif
+
+.if defined(WITH_GMP)
+EXTRACONFIGURE+= enable-gmp
+IGNORE= GMP is LGPLv3 an can not be linked.
+.else
+EXTRACONFIGURE+= no-gmp
+.endif
+
+.if defined(WITH_RFC3779)
+EXTRACONFIGURE+= enable-rfc3779
+.else
+EXTRACONFIGURE+= no-rfc3779
.endif
.if defined(WITH_SCTP)
diff --git a/security/openssl/pkg-plist b/security/openssl/pkg-plist
index d4d1204c0fc1..31329263ca03 100644
--- a/security/openssl/pkg-plist
+++ b/security/openssl/pkg-plist
@@ -34,6 +34,7 @@ include/openssl/idea.h
include/openssl/krb5_asn.h
include/openssl/kssl.h
include/openssl/lhash.h
+%%WITH_MD2%%include/openssl/md2.h
include/openssl/md4.h
include/openssl/md5.h
include/openssl/mdc2.h
@@ -52,6 +53,7 @@ include/openssl/pqueue.h
include/openssl/rand.h
include/openssl/rc2.h
include/openssl/rc4.h
+%%WITH_RC5%%include/openssl/rc5.h
include/openssl/ripemd.h
include/openssl/rsa.h
include/openssl/safestack.h