aboutsummaryrefslogtreecommitdiff
path: root/security/openvas8
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2017-08-06 06:54:47 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2017-08-06 06:54:47 +0000
commit0bc96b6cb198f346a458c8cc4ed69bc02e2151f0 (patch)
tree58d9fe76bd6f4f1bd5072430bfcc5ae7a860b98b /security/openvas8
parentfc904f521b6ee54b2cddd82c136aabfbb1514fc7 (diff)
downloadports-0bc96b6cb198f346a458c8cc4ed69bc02e2151f0.tar.gz
ports-0bc96b6cb198f346a458c8cc4ed69bc02e2151f0.zip
- New port: security/openvas8 (metaport)
This is the metaport to install the mupen64plus emulator and all libraries and tools. WWW: http://www.openvas.org
Notes
Notes: svn path=/head/; revision=447446
Diffstat (limited to 'security/openvas8')
-rw-r--r--security/openvas8/Makefile32
-rw-r--r--security/openvas8/files/pkg-message.in56
-rw-r--r--security/openvas8/pkg-descr4
3 files changed, 92 insertions, 0 deletions
diff --git a/security/openvas8/Makefile b/security/openvas8/Makefile
new file mode 100644
index 000000000000..2d688db44a11
--- /dev/null
+++ b/security/openvas8/Makefile
@@ -0,0 +1,32 @@
+# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= openvas8
+PORTVERSION= 8.0
+CATEGORIES= security
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= openvas 8 vulnerability scanner (metaport)
+
+USES= metaport
+
+# Install OpenVAS libraries
+RUN_DEPENDS+= ${LOCALBASE}/lib/libopenvas_base.so:security/openvas${OPENVAS_VER}-libraries
+
+# Install OpenVAS Commnad Line
+RUN_DEPENDS+= ${LOCALBASE}/bin/omp:security/openvas${OPENVAS_VER}-cli
+
+# Install OpenVAS Manager
+RUN_DEPENDS+= ${LOCALBASE}/sbin/openvasmd:security/openvas${OPENVAS_VER}-manager
+
+# Install OpenVAS Scanner
+RUN_DEPENDS+= ${LOCALBASE}/sbin/openvassd:security/openvas${OPENVAS_VER}-scanner
+
+# Install OpenVAS Web Interface
+RUN_DEPENDS+= ${LOCALBASE}/sbin/gsad:security/greenbone-security-assistant${OPENVAS_VER}
+
+SUB_FILES= pkg-message
+OPENVAS_VER= 8
+
+
+.include <bsd.port.mk>
diff --git a/security/openvas8/files/pkg-message.in b/security/openvas8/files/pkg-message.in
new file mode 100644
index 000000000000..c7c737947700
--- /dev/null
+++ b/security/openvas8/files/pkg-message.in
@@ -0,0 +1,56 @@
+###############################################################################
+
+OpenVAS 8 ports were installed
+
+1) Redis is a dependency of OpenVAS. Please, configure redis-server for
+ listening on socket /tmp/redis.sock. openvassd needs it
+
+2) If you installed security/openvas8-manager port (openvasmd) with PostgrSQL
+ support, please look at:
+
+ %%LOCALBASE%%/share/docs/openvas-scanner/postgres-HOWTO
+
+ It will guide you for configure PostgreSQL as OpenVAS database backend
+ instead of SQLite3
+
+3) The following steps are neccessary before of you can access to OpenVAS web
+ interface (gsad):
+
+ # openvas-mkcert
+ # openvas-mkcert-client -n -i
+ # openvasmd --rebuild --progress
+ # openvas-nvt-sync
+ # openvas-scapdata-sync
+ # openvas-certdata-sync
+ # openvasmd --create-user=admin --role=Admin
+ # openvasmd --user=admin --new-password=yourpassword
+
+4) Add the following lines to /etc/rc.conf
+
+ openvassd_enable="YES"
+ openvasmd_enable="YES"
+ gsad_enable="YES"
+
+5) Start OpenVAS Scanner. It will listen on 127.0.0.1:9391 by default
+
+ # service openvassd restart
+
+6) 5) Start OpenVAS Manager. It will listen on 127.0.0.1:9390 by default
+
+ # service openvasmd restart
+ # openvasmd --rebuild --progress
+
+7) Start OpenVAS web interface. It will listen on http://127.0.0.1:8080 by
+ default
+
+ # service gsad start
+
+8) gsad can export results to PDF. It needs print/texlive-texmf port
+
+ # pkg install texlive-texmf
+
+ It will install 1G of data
+
+9) Enjoy it
+
+###############################################################################
diff --git a/security/openvas8/pkg-descr b/security/openvas8/pkg-descr
new file mode 100644
index 000000000000..bc4ba2fd23fe
--- /dev/null
+++ b/security/openvas8/pkg-descr
@@ -0,0 +1,4 @@
+This is the metaport to install the mupen64plus emulator and all libraries and
+tools.
+
+WWW: http://www.openvas.org