aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn-devel/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-07-21 19:03:27 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-07-21 19:03:27 +0000
commit75ce1dd92c0358703f68a77d6ec19e01f588ad75 (patch)
tree1077693e9e1c54ea781e491b605d6fe38913ae08 /security/openvpn-devel/Makefile
parent0248b2740959f9400189e87c4fa5b73b7774e5cc (diff)
downloadports-75ce1dd92c0358703f68a77d6ec19e01f588ad75.tar.gz
ports-75ce1dd92c0358703f68a77d6ec19e01f588ad75.zip
security/openvpn-devel: update to 2020-W30 snapshot
This is from the PR, with the addition of BUILD_DEPENDS+=rst2man:textproc/py-docutils such that the manpage gets built (it doesn't ship with snapshots - which are from Git - any longer). changes: 08469ca1 Remove --client-cert-not-required 2d5facaa Remove --ifconfig-pool-linear 94edc7c5 Require AEAD support in the crypto library ec7d0e8e Drop support for OpenSSL 1.0.1 df85950a travis: Fix make distcheck failure aad16b6c client-connect: Implement deferred connect support for plugin API v2 3658e577 Separate handling of non-deferred return values for client-connect-scripts. 3d2af156 client-connect: Add deferred support to the client-connect v1 plugin handler 290bb269 client-connect: Use inotify for the deferred client-connect status file 529b1ab2 client-connect: Add deferred support to the client-connect script handler 82241468 Remove CAS_PARTIAL state 4cabd28a doc/man: Do not install man *.rst files 4b4b34da Remove --no-iv 19fab1f6 options: don't leak inline'd key material in logfile 83d6da50 Merge Makefile.am's AUTOMAKE_OPTIONS into configure.ac's AM_INIT_AUTOMAKE. dfb40edc client-connect: Add CC_RET_DEFERRED and cope with deferred client-connect ee6830c3 doc/man: Add misssing renegotiation.rst to Makefile.am 8d0b1def doc/man: Documentation for --bind-dev / VRFs on Linux 5c5544d4 doc/man: Update --txqueuelen default setting (Now OS default) ed593e65 doc/man: Adopt compression documentation 850fd5fa doc/man: Mark compression options as deprecated f500c49c doc/man: convert openvpn.8 to split-up .rst files c83b197a Add deferred authentication support to plugin-auth-pam 90ed0fd2 reformat multi_client_generate_tls_keys according to uncrustify 708d1694 client-connect: Move adding inotify watch into its own function 4d500451 client-connect: Change cas_context from int to enum 07a69fd2 client-connect: Refactor client-connect handling to calling a bunch of hooks in a loop 4f29b73b client-connect: Refactor to use return values instead of modifying a passed-in flag 380a142a client-connect: Move multi_client_connect_setenv into early_setup 62a840e2 client-connect: Refactor multi_client_connect_source_ccd 78359a04 Added support for DHCP option 119 (dns search suffix list) for Windows. 0c8c50ca client-connect: Split multi_connection_established into separate functions b15fcceb Handle connecting clients without NCP or OCC without crashing. PR: 248147 Submitted by: Eric F. Crist (maintainer)
Notes
Notes: svn path=/head/; revision=542781
Diffstat (limited to 'security/openvpn-devel/Makefile')
-rw-r--r--security/openvpn-devel/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/openvpn-devel/Makefile b/security/openvpn-devel/Makefile
index 027c95bee74d..4cd189ec97c7 100644
--- a/security/openvpn-devel/Makefile
+++ b/security/openvpn-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openvpn
-DISTVERSION= 202028
+DISTVERSION= 202030
CATEGORIES= security net net-vpn
MASTER_SITES= https://secure-computing.net/files/openvpn/
PKGNAMESUFFIX= -devel
@@ -78,7 +78,8 @@ SUB_FILES= pkg-message openvpn-client
CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
.endif
-BUILD_DEPENDS+= cmocka>=0:sysutils/cmocka
+BUILD_DEPENDS+= cmocka>=0:sysutils/cmocka \
+ rst2man:textproc/py-docutils
LIB_DEPENDS+= liblzo2.so:archivers/lzo2
LZ4_LIB_DEPENDS+= liblz4.so:archivers/liblz4