aboutsummaryrefslogtreecommitdiff
path: root/security/openvpn20
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-09-30 07:48:24 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-09-30 07:48:24 +0000
commitba70d6b79be14e8163a0674ba6ec2a4235b9bcfb (patch)
tree192843bbf2e0e71eb59cf3d12eeba1a2e9d43aa1 /security/openvpn20
parent33c56fba95319226b53a9776f13a2f60653b963e (diff)
downloadports-ba70d6b79be14e8163a0674ba6ec2a4235b9bcfb.tar.gz
ports-ba70d6b79be14e8163a0674ba6ec2a4235b9bcfb.zip
- Install additional auth-pam plugin
PR: ports/103833 Submitted by: Matthias Andree <matthias.andree at gmx.de> (maintainer) Suggested by: Michael Helmeste Tested by: Michael Helmeste
Notes
Notes: svn path=/head/; revision=174136
Diffstat (limited to 'security/openvpn20')
-rw-r--r--security/openvpn20/Makefile11
-rw-r--r--security/openvpn20/pkg-plist2
2 files changed, 8 insertions, 5 deletions
diff --git a/security/openvpn20/Makefile b/security/openvpn20/Makefile
index 27b982e7ca3f..e86d9ac8d3a7 100644
--- a/security/openvpn20/Makefile
+++ b/security/openvpn20/Makefile
@@ -13,7 +13,7 @@ PORTNAME= openvpn
# WILL BE DROPPED. -- Matthias Andree, 2006-09-13
# -----------------------------------------------------
PORTVERSION= 2.0.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security net
# MASTER_SITES points to hosts in distinct data centers,
# so just one MASTER_SITES entry should be OK.
@@ -65,6 +65,7 @@ CONFIGURE_ARGS+= --enable-password-save
post-build:
cd ${WRKSRC}/plugin/down-root && ${MAKE}
+ cd ${WRKSRC}/plugin/auth-pam && ${CC} ${CFLAGS} ${CPPFLAGS} -I../.. -DDLOPEN_PAM=0 -shared -Wl,-soname,openvpn-auth-pam.so -o openvpn-auth-pam.so auth-pam.c pamdl.c -lc -lpam
@# self-tests here
.if !defined(WITHOUT_CHECK)
cd ${WRKSRC} && ${MAKE} check
@@ -75,12 +76,12 @@ pre-install:
post-install:
${MKDIR} ${PREFIX}/lib
- ${INSTALL_PROGRAM} ${WRKSRC}/plugin/down-root/openvpn-down-root.so \
- ${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${WRKSRC}/plugin/down-root/openvpn-down-root.so ${PREFIX}/lib
+ ${INSTALL_PROGRAM} ${WRKSRC}/plugin/auth-pam/openvpn-auth-pam.so ${PREFIX}/lib
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/plugin/down-root/README \
- ${DOCSDIR}/README.openvpn-down-root
+ ${INSTALL_DATA} ${WRKSRC}/plugin/down-root/README ${DOCSDIR}/README.openvpn-down-root
+ ${INSTALL_DATA} ${WRKSRC}/plugin/auth-pam/README ${DOCSDIR}/README.openvpn-auth-pam
.for docs in AUTHORS COPYING COPYRIGHT.GPL ChangeLog INSTALL NEWS \
PORTS README
${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
diff --git a/security/openvpn20/pkg-plist b/security/openvpn20/pkg-plist
index e91cb935a82a..4df2203dbd05 100644
--- a/security/openvpn20/pkg-plist
+++ b/security/openvpn20/pkg-plist
@@ -1,4 +1,5 @@
sbin/openvpn
+lib/openvpn-auth-pam.so
lib/openvpn-down-root.so
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
@@ -8,6 +9,7 @@ lib/openvpn-down-root.so
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/PORTS
%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.openvpn-auth-pam
%%PORTDOCS%%%%DOCSDIR%%/README.openvpn-down-root
%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/README
%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/build-ca