aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Alt-Crypt-RSA-BigInt
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-09-10 20:26:14 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-09-10 20:26:14 +0000
commit29356cfc9f03194140c568520fa4edd44f82fd48 (patch)
tree036a920dcc91f3d0e80d9b5fa9b281db8d82c8aa /security/p5-Alt-Crypt-RSA-BigInt
parentfbbe99c118357a235fe0f50eb663811746ef1d77 (diff)
downloadports-29356cfc9f03194140c568520fa4edd44f82fd48.tar.gz
ports-29356cfc9f03194140c568520fa4edd44f82fd48.zip
Add p5-Alt-Crypt-RSA-BigInt 0.06
This is a rework of Crypt::RSA to remove Math::Pari and instead base all operations on Math::BigInt. This is intended to be a plug-in replacement for Crypt::RSA, with no user-visible changes to existing features. Math::Pari is completely removed. This includes the two modules: - Crypt::Primes => Math::Prime::Util - Crypt::Random => Math::Prime::Util All operations are now performed using Math::BigInt, and prefer the GMP and Pari backends. WWW: https://metacpan.org/release/Alt-Crypt-RSA-BigInt
Notes
Notes: svn path=/head/; revision=479454
Diffstat (limited to 'security/p5-Alt-Crypt-RSA-BigInt')
-rw-r--r--security/p5-Alt-Crypt-RSA-BigInt/Makefile36
-rw-r--r--security/p5-Alt-Crypt-RSA-BigInt/distinfo3
-rw-r--r--security/p5-Alt-Crypt-RSA-BigInt/pkg-descr14
-rw-r--r--security/p5-Alt-Crypt-RSA-BigInt/pkg-plist30
4 files changed, 83 insertions, 0 deletions
diff --git a/security/p5-Alt-Crypt-RSA-BigInt/Makefile b/security/p5-Alt-Crypt-RSA-BigInt/Makefile
new file mode 100644
index 000000000000..e4b95edcc3a2
--- /dev/null
+++ b/security/p5-Alt-Crypt-RSA-BigInt/Makefile
@@ -0,0 +1,36 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Alt-Crypt-RSA-BigInt
+PORTVERSION= 0.06
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DANAJ
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= RSA public-key cryptosystem, using Math::BigInt
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Class-Loader>=0:devel/p5-Class-Loader \
+ p5-Convert-ASCII-Armour>=0:converters/p5-Convert-ASCII-Armour \
+ p5-Crypt-Blowfish>=0:security/p5-Crypt-Blowfish \
+ p5-Crypt-CBC>=2.17:security/p5-Crypt-CBC \
+ p5-Data-Buffer>=0:misc/p5-Data-Buffer \
+ p5-Digest-MD2>=0:security/p5-Digest-MD2 \
+ p5-Math-BigInt-GMP>=0:math/p5-Math-BigInt-GMP \
+ p5-Math-Prime-Util>=0.64:math/p5-Math-Prime-Util \
+ p5-Math-Prime-Util-GMP>=0:math/p5-Math-Prime-Util-GMP \
+ p5-Sort-Versions>=0:devel/p5-Sort-Versions \
+ p5-Tie-EncryptedHash>=0:security/p5-Tie-EncryptedHash
+
+USES= perl5
+USE_PERL5= configure
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/p5-Alt-Crypt-RSA-BigInt/distinfo b/security/p5-Alt-Crypt-RSA-BigInt/distinfo
new file mode 100644
index 000000000000..71292938e3f1
--- /dev/null
+++ b/security/p5-Alt-Crypt-RSA-BigInt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536593744
+SHA256 (Alt-Crypt-RSA-BigInt-0.06.tar.gz) = 76f434cab36999cdf09811345bb39d6b7cbed7e085b02338328c7f46e08b38f3
+SIZE (Alt-Crypt-RSA-BigInt-0.06.tar.gz) = 52479
diff --git a/security/p5-Alt-Crypt-RSA-BigInt/pkg-descr b/security/p5-Alt-Crypt-RSA-BigInt/pkg-descr
new file mode 100644
index 000000000000..84c8ae7be5b7
--- /dev/null
+++ b/security/p5-Alt-Crypt-RSA-BigInt/pkg-descr
@@ -0,0 +1,14 @@
+This is a rework of Crypt::RSA to remove Math::Pari and instead base all
+operations on Math::BigInt.
+
+This is intended to be a plug-in replacement for Crypt::RSA, with no
+user-visible changes to existing features.
+
+Math::Pari is completely removed. This includes the two modules:
+- Crypt::Primes => Math::Prime::Util
+- Crypt::Random => Math::Prime::Util
+
+All operations are now performed using Math::BigInt, and prefer the GMP and Pari
+backends.
+
+WWW: https://metacpan.org/release/Alt-Crypt-RSA-BigInt
diff --git a/security/p5-Alt-Crypt-RSA-BigInt/pkg-plist b/security/p5-Alt-Crypt-RSA-BigInt/pkg-plist
new file mode 100644
index 000000000000..65b70d1cdeb1
--- /dev/null
+++ b/security/p5-Alt-Crypt-RSA-BigInt/pkg-plist
@@ -0,0 +1,30 @@
+%%SITE_PERL%%/Alt/Crypt/RSA/BigInt.pm
+%%SITE_PERL%%/Crypt/RSA.pm
+%%SITE_PERL%%/Crypt/RSA/DataFormat.pm
+%%SITE_PERL%%/Crypt/RSA/Debug.pm
+%%SITE_PERL%%/Crypt/RSA/ES/OAEP.pm
+%%SITE_PERL%%/Crypt/RSA/ES/PKCS1v15.pm
+%%SITE_PERL%%/Crypt/RSA/Errorhandler.pm
+%%SITE_PERL%%/Crypt/RSA/Key.pm
+%%SITE_PERL%%/Crypt/RSA/Key/Private.pm
+%%SITE_PERL%%/Crypt/RSA/Key/Private/SSH.pm
+%%SITE_PERL%%/Crypt/RSA/Key/Public.pm
+%%SITE_PERL%%/Crypt/RSA/Key/Public/SSH.pm
+%%SITE_PERL%%/Crypt/RSA/Primitives.pm
+%%SITE_PERL%%/Crypt/RSA/SS/PKCS1v15.pm
+%%SITE_PERL%%/Crypt/RSA/SS/PSS.pm
+%%PERL5_MAN3%%/Alt::Crypt::RSA::BigInt.3.gz
+%%PERL5_MAN3%%/Crypt::RSA.3.gz
+%%PERL5_MAN3%%/Crypt::RSA::DataFormat.3.gz
+%%PERL5_MAN3%%/Crypt::RSA::Debug.3.gz
+%%PERL5_MAN3%%/Crypt::RSA::ES::OAEP.3.gz
+%%PERL5_MAN3%%/Crypt::RSA::ES::PKCS1v15.3.gz
+%%PERL5_MAN3%%/Crypt::RSA::Errorhandler.3.gz
+%%PERL5_MAN3%%/Crypt::RSA::Key.3.gz
+%%PERL5_MAN3%%/Crypt::RSA::Key::Private.3.gz
+%%PERL5_MAN3%%/Crypt::RSA::Key::Private::SSH.3.gz
+%%PERL5_MAN3%%/Crypt::RSA::Key::Public.3.gz
+%%PERL5_MAN3%%/Crypt::RSA::Key::Public::SSH.3.gz
+%%PERL5_MAN3%%/Crypt::RSA::Primitives.3.gz
+%%PERL5_MAN3%%/Crypt::RSA::SS::PKCS1v15.3.gz
+%%PERL5_MAN3%%/Crypt::RSA::SS::PSS.3.gz