aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-Htpasswd
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-11-11 13:45:53 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-11-11 13:45:53 +0000
commit184c827a9782c353c372ee70470bd95048f1767c (patch)
tree2de7f55e8ed04613b41372f2433df2e990ed803b /security/p5-Authen-Htpasswd
parentebe4e91dab6ec33f0e46bc4e12672a0308def91e (diff)
downloadports-184c827a9782c353c372ee70470bd95048f1767c.tar.gz
ports-184c827a9782c353c372ee70470bd95048f1767c.zip
Add security/p5-Authen-Htpasswd 0.12, a Perl module to read and modify
apache-style .htpasswd files.
Notes
Notes: svn path=/head/; revision=147922
Diffstat (limited to 'security/p5-Authen-Htpasswd')
-rw-r--r--security/p5-Authen-Htpasswd/Makefile37
-rw-r--r--security/p5-Authen-Htpasswd/distinfo3
-rw-r--r--security/p5-Authen-Htpasswd/pkg-descr7
-rw-r--r--security/p5-Authen-Htpasswd/pkg-plist8
4 files changed, 55 insertions, 0 deletions
diff --git a/security/p5-Authen-Htpasswd/Makefile b/security/p5-Authen-Htpasswd/Makefile
new file mode 100644
index 000000000000..8e98e4faf711
--- /dev/null
+++ b/security/p5-Authen-Htpasswd/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: security/p5-Authen-Htpasswd
+# Date created: 11 November 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Htpasswd
+PORTVERSION= 0.12
+CATEGORIES= security perl5 www
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Authen::Htpasswd - interface to read and modify Apache .htpasswd files
+TAGS= apache authentication pass password md5 sha1 crypto
+
+BUILD_DEPENDS= ${SITE_PERL}/IO/LockedFile.pm:${PORTSDIR}/devel/p5-IO-LockedFile \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/Crypt/PasswdMD5.pm:${PORTSDIR}/security/p5-Crypt-PasswdMD5 \
+ ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Authen::Htpasswd.3 \
+ Authen::Htpasswd::User.3 \
+ Authen::Htpasswd::Util.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Authen-Htpasswd/distinfo b/security/p5-Authen-Htpasswd/distinfo
new file mode 100644
index 000000000000..70c41f6c2c2b
--- /dev/null
+++ b/security/p5-Authen-Htpasswd/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-Htpasswd-0.12.tar.gz) = de2f4589ca3a2216c41fb5492c679c33
+SHA256 (Authen-Htpasswd-0.12.tar.gz) = b2e8a19cfe2711cfc548fc7fa78fdea457075d2f1083558961993f9f71c0483a
+SIZE (Authen-Htpasswd-0.12.tar.gz) = 6604
diff --git a/security/p5-Authen-Htpasswd/pkg-descr b/security/p5-Authen-Htpasswd/pkg-descr
new file mode 100644
index 000000000000..89139f3efd05
--- /dev/null
+++ b/security/p5-Authen-Htpasswd/pkg-descr
@@ -0,0 +1,7 @@
+This module provides a convenient, object-oriented interface to
+Apache-style .htpasswd files. It supports passwords encrypted via MD5,
+SHA1, and crypt, as well as plain (cleartext) passwords. Additional
+fields after username and password, if present, are accessible via the
+extra_info array.
+
+WWW: http://search.cpan.org/dist/Authen-Htpasswd/
diff --git a/security/p5-Authen-Htpasswd/pkg-plist b/security/p5-Authen-Htpasswd/pkg-plist
new file mode 100644
index 000000000000..776c1f77a4e1
--- /dev/null
+++ b/security/p5-Authen-Htpasswd/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Authen/Htpasswd.pm
+%%SITE_PERL%%/Authen/Htpasswd/User.pm
+%%SITE_PERL%%/Authen/Htpasswd/Util.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/Htpasswd/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/Htpasswd 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Authen/Htpasswd 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Authen 2>/dev/null || true