aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Authen-TypeKey/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-05-01 04:04:11 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-05-01 04:04:11 +0000
commita8137202c28ec64b62a403e05d548d0509712a8b (patch)
tree9578db5767f075c2b0d1592550a552a4429ebe90 /security/p5-Authen-TypeKey/Makefile
parentbbf54beefca557e77c02d6507cf3a15a52245d88 (diff)
downloadports-a8137202c28ec64b62a403e05d548d0509712a8b.tar.gz
ports-a8137202c28ec64b62a403e05d548d0509712a8b.zip
add p5-Authen-TypeKey 0.05
TypeKey authentication verification PR: 94679 Submitted by: Gea-Suan Lin <gslin@gslin.org>
Notes
Notes: svn path=/head/; revision=161002
Diffstat (limited to 'security/p5-Authen-TypeKey/Makefile')
-rw-r--r--security/p5-Authen-TypeKey/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/security/p5-Authen-TypeKey/Makefile b/security/p5-Authen-TypeKey/Makefile
new file mode 100644
index 000000000000..032c4012d040
--- /dev/null
+++ b/security/p5-Authen-TypeKey/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Authen-TypeKey
+# Date created: 2006-03-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-TypeKey
+PORTVERSION= 0.05
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= TypeKey authentication verification
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/Class/ErrorHandler.pm:${PORTSDIR}/devel/p5-Class-ErrorHandler \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/Math/BigInt.pm:${PORTSDIR}/math/p5-Math-BigInt
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Authen::TypeKey.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>