aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-Ctr
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-18 21:59:47 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-18 21:59:47 +0000
commit429feed8fca4ac2199e7ddbed0637f19bd2bcee9 (patch)
tree25a25fe59449a0c1158207e2425fe735aac9b686 /security/p5-Crypt-Ctr
parent23be9d08e950f6f49d8a91b5b41048d3cb6c3659 (diff)
downloadports-429feed8fca4ac2199e7ddbed0637f19bd2bcee9.tar.gz
ports-429feed8fca4ac2199e7ddbed0637f19bd2bcee9.zip
Generic Counter Mode implementation in pure Perl. The Counter Mode module
constructs a stream cipher from a block cipher or cryptographic hash funtion and returns it as an object. Any block cipher in the Crypt:: class can be used, as long as it supports the blocksize and keysize methods. Any hash function in the Digest:: class can be used, as long as it supports the add method. WWW: http://search.cpan.org/dist/Crypt-Ctr PR: ports/90613 Submitted by: Gabor Kovesdan
Notes
Notes: svn path=/head/; revision=151519
Diffstat (limited to 'security/p5-Crypt-Ctr')
-rw-r--r--security/p5-Crypt-Ctr/Makefile24
-rw-r--r--security/p5-Crypt-Ctr/distinfo3
-rw-r--r--security/p5-Crypt-Ctr/pkg-descr8
-rw-r--r--security/p5-Crypt-Ctr/pkg-plist5
4 files changed, 40 insertions, 0 deletions
diff --git a/security/p5-Crypt-Ctr/Makefile b/security/p5-Crypt-Ctr/Makefile
new file mode 100644
index 000000000000..49ddc6fef771
--- /dev/null
+++ b/security/p5-Crypt-Ctr/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-Ctr
+# Date created: 18 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-Ctr
+PORTVERSION= 0.01
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for encrypting data in Counter Mode
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Ctr.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-Ctr/distinfo b/security/p5-Crypt-Ctr/distinfo
new file mode 100644
index 000000000000..ad3f1d10cfe5
--- /dev/null
+++ b/security/p5-Crypt-Ctr/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-Ctr-0.01.tar.gz) = 2f5e1192078827c1425ae2d9e527211b
+SHA256 (Crypt-Ctr-0.01.tar.gz) = 1835a9af5fb36790d0d8ace2abe5f3d42caaad8ef431fbc7e9be4487e2af6a9c
+SIZE (Crypt-Ctr-0.01.tar.gz) = 7253
diff --git a/security/p5-Crypt-Ctr/pkg-descr b/security/p5-Crypt-Ctr/pkg-descr
new file mode 100644
index 000000000000..6f1328d90a3c
--- /dev/null
+++ b/security/p5-Crypt-Ctr/pkg-descr
@@ -0,0 +1,8 @@
+Generic Counter Mode implementation in pure Perl. The Counter Mode module
+constructs a stream cipher from a block cipher or cryptographic hash funtion
+and returns it as an object. Any block cipher in the Crypt:: class can be
+used, as long as it supports the blocksize and keysize methods. Any hash
+function in the Digest:: class can be used, as long as it supports
+the add method.
+
+WWW: http://search.cpan.org/dist/Crypt-Ctr
diff --git a/security/p5-Crypt-Ctr/pkg-plist b/security/p5-Crypt-Ctr/pkg-plist
new file mode 100644
index 000000000000..8695dbd029e2
--- /dev/null
+++ b/security/p5-Crypt-Ctr/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/Ctr.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Ctr/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Ctr/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true