aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-GpgME
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-05-02 09:18:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-05-02 09:18:08 +0000
commit1dd4f00e758015ba15a854ff8ecda6ec205d95a8 (patch)
tree1dd5ec404b4eaeea2faad7fc7cf63623fe3e18be /security/p5-Crypt-GpgME
parente0f8816b35009be48ccc57ac1cdff7478a77137b (diff)
downloadports-1dd4f00e758015ba15a854ff8ecda6ec205d95a8.tar.gz
ports-1dd4f00e758015ba15a854ff8ecda6ec205d95a8.zip
security/p5-Crypt-GpgME (new port): Perl interface to libgpgme.
Diffstat (limited to 'security/p5-Crypt-GpgME')
-rw-r--r--security/p5-Crypt-GpgME/Makefile34
-rw-r--r--security/p5-Crypt-GpgME/distinfo3
-rw-r--r--security/p5-Crypt-GpgME/pkg-descr3
-rw-r--r--security/p5-Crypt-GpgME/pkg-plist5
4 files changed, 45 insertions, 0 deletions
diff --git a/security/p5-Crypt-GpgME/Makefile b/security/p5-Crypt-GpgME/Makefile
new file mode 100644
index 000000000000..4fb7852a13dd
--- /dev/null
+++ b/security/p5-Crypt-GpgME/Makefile
@@ -0,0 +1,34 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+
+PORTNAME= Crypt-GpgME
+PORTVERSION= 0.09
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl interface to libgpgme
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+LIB_DEPENDS= libassuan.so:security/libassuan \
+ libgpg-error.so:security/libgpg-error \
+ libgpgme.so:security/gpgme
+RUN_DEPENDS= p5-IO-Stringy>=0:devel/p5-IO-Stringy
+TEST_DEPENDS= p5-Test-Exception>=0:devel/p5-Test-Exception
+
+USES= gmake localbase perl5
+USE_PERL5= configure
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/Changes ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-GpgME/distinfo b/security/p5-Crypt-GpgME/distinfo
new file mode 100644
index 000000000000..4dd7b3104a61
--- /dev/null
+++ b/security/p5-Crypt-GpgME/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1258498777
+SHA256 (Crypt-GpgME-0.09.tar.gz) = fd76ae6f9ea2d58e9830cb038014741fc97241f703afaf80b4ea2cffe1eaadad
+SIZE (Crypt-GpgME-0.09.tar.gz) = 69896
diff --git a/security/p5-Crypt-GpgME/pkg-descr b/security/p5-Crypt-GpgME/pkg-descr
new file mode 100644
index 000000000000..8fe10fad1296
--- /dev/null
+++ b/security/p5-Crypt-GpgME/pkg-descr
@@ -0,0 +1,3 @@
+Crypt::GpgME is Perl interface to libgpgme.
+
+WWW: https://metacpan.org/dist/Crypt-GpgME
diff --git a/security/p5-Crypt-GpgME/pkg-plist b/security/p5-Crypt-GpgME/pkg-plist
new file mode 100644
index 000000000000..40011ace76f7
--- /dev/null
+++ b/security/p5-Crypt-GpgME/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_ARCH%%/Crypt/GpgME.pm
+%%SITE_ARCH%%/auto/Crypt/GpgME/GpgME.so
+%%PERL5_MAN3%%/Crypt::GpgME.3.gz
+%%PORTDOCS%%%%DOCSDIR%%/Changes
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sign.pl