aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-IDEA/Makefile
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 08:35:48 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 08:35:48 +0000
commit04860148c33f35b49ac80b68989d7f0981afc225 (patch)
treeab1471ffdbc2ad86f491492a21cfdc088aea1dbe /security/p5-Crypt-IDEA/Makefile
parent1e8ba55efad8fbe76d161f03ea398fabd63f3db3 (diff)
downloadports-04860148c33f35b49ac80b68989d7f0981afc225.tar.gz
ports-04860148c33f35b49ac80b68989d7f0981afc225.zip
perl5 interface to IDEA block cipher.
Notes
Notes: svn path=/head/; revision=4117
Diffstat (limited to 'security/p5-Crypt-IDEA/Makefile')
-rw-r--r--security/p5-Crypt-IDEA/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/security/p5-Crypt-IDEA/Makefile b/security/p5-Crypt-IDEA/Makefile
new file mode 100644
index 000000000000..03b51a3ec4cc
--- /dev/null
+++ b/security/p5-Crypt-IDEA/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Crypt-IDEA
+# Version required: 1.0
+# Date created: October 20th 1996
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= Crypt-IDEA-1.0
+PKGNAME= p5-Crypt-IDEA-1.0
+CATEGORIES+= security
+MASTER_SITES= ftp://ftp.digital.com/pub/plan/perl/CPAN/modules/by-module/Crypt/ \
+ ftp://ftp.cdrom.com/pub/perl/CPAN/modules/by-module/Crypt/ \
+ ftp://ftp.cis.ufl.edu/pub/perl/CPAN/modules/by-module/Crypt/ \
+ ftp://ftp.leo.org/pub/comp/programming/languages/perl/CPAN/modules/by-module/Crypt/ \
+ ftp://ftp.demon.co.uk/pub/mirrors/perl/CPAN/modules/by-module/Crypt/ \
+ ftp://ftp.lab.kdd.co.jp/lang/perl/CPAN/modules/by-module/Crypt/
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ @ for file in Crypt::IDEA; do \
+ gzip -9nf ${PREFIX}/lib/perl5/man/man3/$$file.3; \
+ done
+.endif
+
+.include <bsd.port.mk>