aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Crypt-OpenSSL-RSA
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-16 11:08:10 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-04-16 11:08:10 +0000
commitbd4520afe48e485771f4662f9689b7f1c11b6f6e (patch)
treea530748bdfaac0cb103e0f4ddb833d0ed336cca5 /security/p5-Crypt-OpenSSL-RSA
parenta644e6fed11b00ff7ac2858f6ad694f766205f9c (diff)
downloadports-bd4520afe48e485771f4662f9689b7f1c11b6f6e.tar.gz
ports-bd4520afe48e485771f4662f9689b7f1c11b6f6e.zip
Add LICENSE
- Use BROKEN_SSL - Remove regression-test: - Sort PLIST
Notes
Notes: svn path=/head/; revision=438641
Diffstat (limited to 'security/p5-Crypt-OpenSSL-RSA')
-rw-r--r--security/p5-Crypt-OpenSSL-RSA/Makefile16
-rw-r--r--security/p5-Crypt-OpenSSL-RSA/pkg-plist2
2 files changed, 7 insertions, 11 deletions
diff --git a/security/p5-Crypt-OpenSSL-RSA/Makefile b/security/p5-Crypt-OpenSSL-RSA/Makefile
index 4599bce26277..4aa948f34d01 100644
--- a/security/p5-Crypt-OpenSSL-RSA/Makefile
+++ b/security/p5-Crypt-OpenSSL-RSA/Makefile
@@ -11,21 +11,17 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 module to RSA encode and decode strings using OpenSSL
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
BUILD_DEPENDS= p5-Crypt-OpenSSL-Bignum>=0:security/p5-Crypt-OpenSSL-Bignum \
p5-Crypt-OpenSSL-Random>=0:security/p5-Crypt-OpenSSL-Random
RUN_DEPENDS:= ${BUILD_DEPENDS}
+BROKEN_SSL= openssl-devel
+
USES= perl5 ssl
USE_PERL5= configure
MAKE_ARGS= PASTHRU_INC=-I${OPENSSLINC}
-regression-test: build
- cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} test
-
-.include <bsd.port.pre.mk>
-
-.if ${SSL_DEFAULT:Mopenssl-devel}
-BROKEN= Does not build with openssl-devel
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OpenSSL-RSA/pkg-plist b/security/p5-Crypt-OpenSSL-RSA/pkg-plist
index 528d81605f77..7a690d04636b 100644
--- a/security/p5-Crypt-OpenSSL-RSA/pkg-plist
+++ b/security/p5-Crypt-OpenSSL-RSA/pkg-plist
@@ -1,4 +1,3 @@
-%%PERL5_MAN3%%/Crypt::OpenSSL::RSA.3.gz
%%SITE_ARCH%%/Crypt/OpenSSL/RSA.pm
%%SITE_ARCH%%/auto/Crypt/OpenSSL/RSA/RSA.so
%%SITE_ARCH%%/auto/Crypt/OpenSSL/RSA/autosplit.ix
@@ -6,3 +5,4 @@
%%SITE_ARCH%%/auto/Crypt/OpenSSL/RSA/import_random_seed.al
%%SITE_ARCH%%/auto/Crypt/OpenSSL/RSA/new_key_from_parameters.al
%%SITE_ARCH%%/auto/Crypt/OpenSSL/RSA/new_public_key.al
+%%PERL5_MAN3%%/Crypt::OpenSSL::RSA.3.gz