aboutsummaryrefslogtreecommitdiff
path: root/security/p5-File-KeePass-Agent/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2013-06-28 00:02:47 +0000
committerCy Schubert <cy@FreeBSD.org>2013-06-28 00:02:47 +0000
commit04d5039845cfb37cf4ae45fd328229d7864ba1a4 (patch)
tree29c18022a5b667097e91efd8e7ea5446badd2c96 /security/p5-File-KeePass-Agent/Makefile
parentbc71f564c634fdb2365635404a02f159137aedef (diff)
downloadports-04d5039845cfb37cf4ae45fd328229d7864ba1a4.tar.gz
ports-04d5039845cfb37cf4ae45fd328229d7864ba1a4.zip
Add File::KeePass::Agent An application agent for working with
File::KeePass objects.
Notes
Notes: svn path=/head/; revision=321913
Diffstat (limited to 'security/p5-File-KeePass-Agent/Makefile')
-rw-r--r--security/p5-File-KeePass-Agent/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/security/p5-File-KeePass-Agent/Makefile b/security/p5-File-KeePass-Agent/Makefile
new file mode 100644
index 000000000000..9604266a48b2
--- /dev/null
+++ b/security/p5-File-KeePass-Agent/Makefile
@@ -0,0 +1,28 @@
+# Created by: Cy Schubert <cy@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= File-KeePass-Agent
+PORTVERSION= 2.01
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cy@FreeBSD.org
+COMMENT= Application agent for working with File::KeePass objects
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-File-KeePass>=2.03:${PORTSDIR}/security/p5-File-KeePass \
+ p5-Crypt-Rijndael>=1.0:${PORTSDIR}/security/p5-Crypt-Rijndael \
+ p5-MIME-Base64>=1.0:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= fkp-agent.1
+MAN3= File::KeePass::Agent.3 \
+ File::KeePass::Agent::linux.3 \
+ File::KeePass::Agent::unix.3
+
+.include <bsd.port.mk>