aboutsummaryrefslogtreecommitdiff
path: root/security/p5-MD5/Makefile
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 08:37:23 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1996-10-24 08:37:23 +0000
commitb836b50aa4fa6bf750c3aac745f5ee9f6629aea1 (patch)
tree6e00ef51e3b380572d68ecf2d162d595be950a49 /security/p5-MD5/Makefile
parent04860148c33f35b49ac80b68989d7f0981afc225 (diff)
downloadports-b836b50aa4fa6bf750c3aac745f5ee9f6629aea1.tar.gz
ports-b836b50aa4fa6bf750c3aac745f5ee9f6629aea1.zip
perl5 interface to the RSA Data Security Inc. MD5 Message-Digest Algorithm
Notes
Notes: svn path=/head/; revision=4118
Diffstat (limited to 'security/p5-MD5/Makefile')
-rw-r--r--security/p5-MD5/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/security/p5-MD5/Makefile b/security/p5-MD5/Makefile
new file mode 100644
index 000000000000..80e504e1f967
--- /dev/null
+++ b/security/p5-MD5/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-MD5
+# Version required: 1.7
+# Date created: September 30th 1996
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= MD5-1.7
+PKGNAME= p5-MD5-1.7
+CATEGORIES+= security
+MASTER_SITES= ftp://ftp.digital.com/pub/plan/perl/CPAN/modules/by-module/MD5/ \
+ ftp://ftp.cdrom.com/pub/perl/CPAN/modules/by-module/MD5/ \
+ ftp://ftp.cis.ufl.edu/pub/perl/CPAN/modules/by-module/MD5/ \
+ ftp://ftp.leo.org/pub/comp/programming/languages/perl/CPAN/modules/by-module/MD5/ \
+ ftp://ftp.demon.co.uk/pub/mirrors/perl/CPAN/modules/by-module/MD5/ \
+ ftp://ftp.lab.kdd.co.jp/lang/perl/CPAN/modules/by-module/MD5/
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= perl5.003:${PORTSDIR}/lang/perl5
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+post-install:
+.if !defined(NOMANCOMPRESS)
+ @ gzip -9nf ${PREFIX}/lib/perl5/man/man3/MD5.3
+.endif
+
+.include <bsd.port.mk>