aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Module-Signature
diff options
context:
space:
mode:
authorJase Thew <jase@FreeBSD.org>2012-11-23 15:55:30 +0000
committerJase Thew <jase@FreeBSD.org>2012-11-23 15:55:30 +0000
commit8c849a82dfedf90b98400dc9b7be36d43dc6db60 (patch)
tree6c597da6eb9084b0c31de909a8e3c537820b5af0 /security/p5-Module-Signature
parent7ce4d1bcd3e1c071c289ad33e6e8f86dc6ab393a (diff)
downloadports-8c849a82dfedf90b98400dc9b7be36d43dc6db60.tar.gz
ports-8c849a82dfedf90b98400dc9b7be36d43dc6db60.zip
- Remove hardcoded dependency on security/gpg. Instead, add OPTIONS to allow
choice of GnuPG version. PR: ports/172323 Approved by: jadawin (perl@) Feature safe: yes
Notes
Notes: svn path=/head/; revision=307682
Diffstat (limited to 'security/p5-Module-Signature')
-rw-r--r--security/p5-Module-Signature/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/security/p5-Module-Signature/Makefile b/security/p5-Module-Signature/Makefile
index 533bedea0994..94995b78343c 100644
--- a/security/p5-Module-Signature/Makefile
+++ b/security/p5-Module-Signature/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Module-Signature
PORTVERSION= 0.69
+PORTREVISION= 1
CATEGORIES= security perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,8 +12,7 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Module signature file manipulation
BUILD_DEPENDS= p5-IPC-Run>=0:${PORTSDIR}/devel/p5-IPC-Run \
- p5-PAR-Dist>=0:${PORTSDIR}/devel/p5-PAR-Dist \
- ${LOCALBASE}/bin/gpg:${PORTSDIR}/security/gnupg1
+ p5-PAR-Dist>=0:${PORTSDIR}/devel/p5-PAR-Dist
RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFIGURE_ENV= PERL_MM_USE_DEFAULT="yes"
@@ -21,8 +21,24 @@ PERL_CONFIGURE= yes
MAN1= cpansign.1
MAN3= Module::Signature.3
+OPTIONS_DEFAULT= GPG2
+OPTIONS_MULTI= GPG
+OPTIONS_MULTI_GPG= GPG1 GPG2
+GPG1_DESC= Use GnuPG version 1
+GPG2_DESC= Use GnuPG version 2
+
.include <bsd.port.pre.mk>
+.if ${PORT_OPTIONS:MGPG1}
+BUILD_DEPENDS+= ${LOCALBASE}/bin/gpgv:${PORTSDIR}/security/gnupg1
+RUN_DEPENDS+= ${LOCALBASE}/bin/gpgv:${PORTSDIR}/security/gnupg1
+.endif
+
+.if ${PORT_OPTIONS:MGPG2}
+BUILD_DEPENDS+= ${LOCALBASE}/bin/gpgv2:${PORTSDIR}/security/gnupg
+RUN_DEPENDS+= ${LOCALBASE}/bin/gpgv2:${PORTSDIR}/security/gnupg
+.endif
+
.if ${PERL_LEVEL} < 501000
BUILD_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA