aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Net-SSLeay
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-12-31 10:00:16 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-12-31 10:00:16 +0000
commit6e38d834c8ac34629cf90700af1dfe86dc3a61fd (patch)
treed6dadfbf460dd4e5b09dc5057c762628a4d9ebd0 /security/p5-Net-SSLeay
parentc7cc76ac5864dc77b3539c4cde1f0f03809d0600 (diff)
downloadports-6e38d834c8ac34629cf90700af1dfe86dc3a61fd.tar.gz
ports-6e38d834c8ac34629cf90700af1dfe86dc3a61fd.zip
- update to Net-SSLeay-1.30
- assign to perl@
Notes
Notes: svn path=/head/; revision=152481
Diffstat (limited to 'security/p5-Net-SSLeay')
-rw-r--r--security/p5-Net-SSLeay/Makefile15
-rw-r--r--security/p5-Net-SSLeay/distinfo6
-rw-r--r--security/p5-Net-SSLeay/files/extrapatch-SSLeay.xs16
3 files changed, 31 insertions, 6 deletions
diff --git a/security/p5-Net-SSLeay/Makefile b/security/p5-Net-SSLeay/Makefile
index f0ce5f806756..77964685f68f 100644
--- a/security/p5-Net-SSLeay/Makefile
+++ b/security/p5-Net-SSLeay/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= Net-SSLeay
-PORTVERSION= 1.25
+PORTVERSION= 1.30
CATEGORIES= security perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
PKGNAMEPREFIX= p5-
DISTNAME= Net_SSLeay.pm-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 interface to SSL
PERL_CONFIGURE= yes
@@ -32,4 +32,13 @@ post-install:
${INSTALL_DATA} ${SRCDIR}/req.conf ${EXAMPLESDIR}/req.conf
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-SSLeay.xs
+
+post-patch:
+ ${PERL} -pi -e 's/\$\^V/\$\]/' ${WRKSRC}/Net-SSLeay-Handle-*/Handle.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Net-SSLeay/distinfo b/security/p5-Net-SSLeay/distinfo
index 1c979416707e..53c896dfb082 100644
--- a/security/p5-Net-SSLeay/distinfo
+++ b/security/p5-Net-SSLeay/distinfo
@@ -1,3 +1,3 @@
-MD5 (Net_SSLeay.pm-1.25.tar.gz) = 87de8a06802fbb63c7c85e89eedbe139
-SHA256 (Net_SSLeay.pm-1.25.tar.gz) = fa70ed320fa6e7ac76ecf5577b2c4a3901d41e3910bd02e129c40f020a7c12e4
-SIZE (Net_SSLeay.pm-1.25.tar.gz) = 77485
+MD5 (Net_SSLeay.pm-1.30.tar.gz) = b0cd6c1681bbc0695d81be5cd852d1d0
+SHA256 (Net_SSLeay.pm-1.30.tar.gz) = 408455f60e616aed0defa8f0a6beb6ffea219d3a8fdb436371afa0a6b35c38c5
+SIZE (Net_SSLeay.pm-1.30.tar.gz) = 78629
diff --git a/security/p5-Net-SSLeay/files/extrapatch-SSLeay.xs b/security/p5-Net-SSLeay/files/extrapatch-SSLeay.xs
new file mode 100644
index 000000000000..3945c4adfd75
--- /dev/null
+++ b/security/p5-Net-SSLeay/files/extrapatch-SSLeay.xs
@@ -0,0 +1,16 @@
+--- SSLeay.xs.orig Sat Dec 31 17:20:25 2005
++++ SSLeay.xs Sat Dec 31 17:23:39 2005
+@@ -94,6 +94,13 @@
+ }
+ #endif
+
++#ifndef XST_mPVN
++#define XST_mPVN(i,v,n) (ST(i) = sv_2mortal(newSVpvn(v,n)))
++#endif
++#ifndef XSRETURN_PVN
++#define XSRETURN_PVN(v,n) STMT_START { XST_mPVN(0,v,n); XSRETURN(1); } STMT_END
++#endif
++
+ /* OpenSSL-0.9.3a has some strange warning about this in
+ * openssl/des.h
+ */