aboutsummaryrefslogtreecommitdiff
path: root/security/p5-Net-SinFP
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-09-30 15:36:00 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-09-30 15:36:00 +0000
commit13656ce7679181f0b1b776ed95b711d9370fe971 (patch)
treeaba3625b969faf5c3d2b6bd501ca2207adbb3456 /security/p5-Net-SinFP
parente34dada69d0bfe8ee356ea9bff09dd06291b8a28 (diff)
downloadports-13656ce7679181f0b1b776ed95b711d9370fe971.tar.gz
ports-13656ce7679181f0b1b776ed95b711d9370fe971.zip
- Separate sinfp into library (p5-Net-SinFP) and binary+db (sinfp)
- Use latest db snapshot
Notes
Notes: svn path=/head/; revision=174188
Diffstat (limited to 'security/p5-Net-SinFP')
-rw-r--r--security/p5-Net-SinFP/Makefile22
-rw-r--r--security/p5-Net-SinFP/distinfo3
-rw-r--r--security/p5-Net-SinFP/pkg-descr2
-rw-r--r--security/p5-Net-SinFP/pkg-plist2
4 files changed, 21 insertions, 8 deletions
diff --git a/security/p5-Net-SinFP/Makefile b/security/p5-Net-SinFP/Makefile
index 494b1e2a264f..07720ca77ee8 100644
--- a/security/p5-Net-SinFP/Makefile
+++ b/security/p5-Net-SinFP/Makefile
@@ -1,20 +1,28 @@
-# New ports collection makefile for: SinFP
+# New ports collection makefile for: p5-Net-SinFP
# Date created: 26 May 2006
# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= Net-SinFP
-PORTVERSION= 2.02.1
+PORTNAME?= Net-SinFP
DISTVERSION= 2.02
-PORTREVISION= 1
CATEGORIES= security ipv6 perl5
-MASTER_SITES= CPAN
+MASTER_SITES= CPAN/Net
+DISTNAME= Net-SinFP-${DISTVERSION}
+.ifdef DBDATE
+PORTREVISION= ${DBDATE}
+MASTER_SITES+= http://www.gomor.org/files/:DB CSME:DB
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}-${DBDATE}.db:DB
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+.endif
MAINTAINER= infofarmer@FreeBSD.org
COMMENT= Full operating system stack fingerprinting suite
+.if ${PORTNAME} == "Net-SinFP"
+PKGNAMEPREFIX= p5-
+
BUILD_DEPENDS= p5-Class-Gomor>=1.00:${PORTSDIR}/devel/p5-Class-Gomor \
p5-DBIx-SQLite-Simple>=0.33:${PORTSDIR}/databases/p5-DBIx-SQLite-Simple \
p5-Net-Packet>=3.00:${PORTSDIR}/net/p5-Net-Packet \
@@ -30,6 +38,10 @@ MAN3= Net::SinFP.3 Net::SinFP::Consts.3 Net::SinFP::DB.3 Net::SinFP::DB::IpVersi
Net::SinFP::DB::Signature.3 Net::SinFP::DB::SystemClass.3 Net::SinFP::DB::Vendor.3 \
Net::SinFP::Result.3 Net::SinFP::Search.3 Net::SinFP::SinFP4.3 Net::SinFP::SinFP6.3
+post-patch:
+ ${REINPLACE_CMD} -e 's/.*EXE_FILES.*//' ${WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
+
ONLY_FOR_ARCHS= i386 amd64 alpha
ONLY_FOR_ARCHS_REASON= Big endian architectures not supported yet
diff --git a/security/p5-Net-SinFP/distinfo b/security/p5-Net-SinFP/distinfo
index 3f9cc4d1f0b9..2f7275230530 100644
--- a/security/p5-Net-SinFP/distinfo
+++ b/security/p5-Net-SinFP/distinfo
@@ -1,3 +1,6 @@
MD5 (Net-SinFP-2.02.tar.gz) = 9200a258e3f1e2cde3a57fe483e0c172
SHA256 (Net-SinFP-2.02.tar.gz) = a986a7f548f49a91ba64780e70746c2da5296a13a21282656fae49c50fb461e9
SIZE (Net-SinFP-2.02.tar.gz) = 25218
+MD5 (sinfp-20060923.db) = b6f26fbc88ccf705f60cdfa1d456e2d1
+SHA256 (sinfp-20060923.db) = 2709b311686f03e09525df47d30d614dc052d6fc3c642d9881400a60a1d290a3
+SIZE (sinfp-20060923.db) = 33792
diff --git a/security/p5-Net-SinFP/pkg-descr b/security/p5-Net-SinFP/pkg-descr
index 3568b7ed5828..568a6487d02e 100644
--- a/security/p5-Net-SinFP/pkg-descr
+++ b/security/p5-Net-SinFP/pkg-descr
@@ -12,5 +12,5 @@ operating system. That is, it only requires one open TCP port, sends
only fully standard TCP packets, and limits the number of tests to 2
or 3 (with only 1 test giving the OS reliably in most cases).
-WWW: http://www.gomor.org/sinfp
+WWW: http://search.cpan.org/dist/Net-SinFP/
Author: GomoR <netpkt@gomor.org>
diff --git a/security/p5-Net-SinFP/pkg-plist b/security/p5-Net-SinFP/pkg-plist
index b781d3c2ab9b..dbc77760a935 100644
--- a/security/p5-Net-SinFP/pkg-plist
+++ b/security/p5-Net-SinFP/pkg-plist
@@ -1,5 +1,3 @@
-bin/sinfp.db
-bin/sinfp.pl
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SinFP/.packlist
%%SITE_PERL%%/Net/SinFP.pm
%%SITE_PERL%%/Net/SinFP/Consts.pm