aboutsummaryrefslogtreecommitdiff
path: root/security/p5-OpenCA-X509
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-03-09 19:30:46 +0000
committerSteve Wills <swills@FreeBSD.org>2012-03-09 19:30:46 +0000
commit019c0460b1620d6eae869986271df02f8e9200cf (patch)
tree493b6d96fe008402eaa2f7e83a9b7a59f99d0c0b /security/p5-OpenCA-X509
parent383222b6e1a4c91c30de402605c5e46fb933d552 (diff)
downloadports-019c0460b1620d6eae869986271df02f8e9200cf.tar.gz
ports-019c0460b1620d6eae869986271df02f8e9200cf.zip
Perl extension for handling X509 Certificates
Notes
Notes: svn path=/head/; revision=293021
Diffstat (limited to 'security/p5-OpenCA-X509')
-rw-r--r--security/p5-OpenCA-X509/Makefile23
-rw-r--r--security/p5-OpenCA-X509/distinfo2
-rw-r--r--security/p5-OpenCA-X509/pkg-descr3
-rw-r--r--security/p5-OpenCA-X509/pkg-plist6
4 files changed, 34 insertions, 0 deletions
diff --git a/security/p5-OpenCA-X509/Makefile b/security/p5-OpenCA-X509/Makefile
new file mode 100644
index 000000000000..825bbdb63a24
--- /dev/null
+++ b/security/p5-OpenCA-X509/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-OpenCA-X509
+# Date created: 2012-03-09
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= OpenCA-X509
+PORTVERSION= 0.9.10
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MADWOLF
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl extension for handling X509 Certificates
+
+BUILD_DEPENDS= p5-X500-DN>=0:${PORTSDIR}/net/p5-X500-DN
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/security/p5-OpenCA-X509/distinfo b/security/p5-OpenCA-X509/distinfo
new file mode 100644
index 000000000000..501a59c835ff
--- /dev/null
+++ b/security/p5-OpenCA-X509/distinfo
@@ -0,0 +1,2 @@
+SHA256 (OpenCA-X509-0.9.10.tar.gz) = c9cccca39771a67cda711a19f28684eeee4c537eac0c7a8a629c399e21ac1119
+SIZE (OpenCA-X509-0.9.10.tar.gz) = 8784
diff --git a/security/p5-OpenCA-X509/pkg-descr b/security/p5-OpenCA-X509/pkg-descr
new file mode 100644
index 000000000000..b1fe06ef17cb
--- /dev/null
+++ b/security/p5-OpenCA-X509/pkg-descr
@@ -0,0 +1,3 @@
+Perl extension for handling X509 Certificates
+
+WWW: http://search.cpan.org/dist/OpenCA-X509/
diff --git a/security/p5-OpenCA-X509/pkg-plist b/security/p5-OpenCA-X509/pkg-plist
new file mode 100644
index 000000000000..c99fe47f0220
--- /dev/null
+++ b/security/p5-OpenCA-X509/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenCA/X509/.packlist
+%%SITE_PERL%%/OpenCA/X509.pm
+%%SITE_PERL%%/OpenCA/prova.pl
+@dirrmtry %%SITE_PERL%%/OpenCA
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenCA/X509
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/OpenCA