aboutsummaryrefslogtreecommitdiff
path: root/security/pam_af
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-10-01 20:05:53 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-10-01 20:05:53 +0000
commitdcd18738cc7ea0e60c5ba6ea6f8584eeec6f090b (patch)
treee92e547fa0789815d15976667a3d64ab80a2aee1 /security/pam_af
parent65f007bbf9ae028b32a43c6aca9e85316f73b40d (diff)
downloadports-dcd18738cc7ea0e60c5ba6ea6f8584eeec6f090b.tar.gz
ports-dcd18738cc7ea0e60c5ba6ea6f8584eeec6f090b.zip
- Fix compiling with oncoming gcc41.
Reported by: pointyhat run Approved by: sem (mentor)
Notes
Notes: svn path=/head/; revision=174262
Diffstat (limited to 'security/pam_af')
-rw-r--r--security/pam_af/Makefile2
-rw-r--r--security/pam_af/files/patch-common_subr.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/security/pam_af/Makefile b/security/pam_af/Makefile
index 70556ad8e89e..a5883cc55585 100644
--- a/security/pam_af/Makefile
+++ b/security/pam_af/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 1.0
CATEGORIES= security
MASTER_SITES= http://mbsd.msk.ru/dist/
-MAINTAINER= ssedov@mbsd.msk.ru
+MAINTAINER= stas@FreeBSD.org
COMMENT= Anti-bruteforce PAM module
USE_BZIP2= yes
diff --git a/security/pam_af/files/patch-common_subr.c b/security/pam_af/files/patch-common_subr.c
new file mode 100644
index 000000000000..807db943817d
--- /dev/null
+++ b/security/pam_af/files/patch-common_subr.c
@@ -0,0 +1,11 @@
+--- common/subr.c.orig Sun Oct 1 18:13:16 2006
++++ common/subr.c Sun Oct 1 18:14:09 2006
+@@ -322,7 +322,7 @@
+ const char *db;
+ char *host;
+ {
+- datum key, data;
++ datum key, data = {NULL, 0};
+ struct myaddrinfo *res0, *res;
+ static hostrule_t hstent;
+ int found = 0;