aboutsummaryrefslogtreecommitdiff
path: root/security/pam_krb5/Makefile
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2003-02-12 04:38:19 +0000
committerCy Schubert <cy@FreeBSD.org>2003-02-12 04:38:19 +0000
commite103223c78ee4dcab56b63865efd539168c9f9c3 (patch)
tree97d5fb5fd005ecb9ac567e5db861d047807aec42 /security/pam_krb5/Makefile
parentcb9a70023bc23ad85b6f2d4fcb2d2fda214e53e1 (diff)
downloadports-e103223c78ee4dcab56b63865efd539168c9f9c3.tar.gz
ports-e103223c78ee4dcab56b63865efd539168c9f9c3.zip
Resurrect pam_krb5 for MIT KRB5.
Approved by: nectar
Notes
Notes: svn path=/head/; revision=75340
Diffstat (limited to 'security/pam_krb5/Makefile')
-rw-r--r--security/pam_krb5/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/security/pam_krb5/Makefile b/security/pam_krb5/Makefile
new file mode 100644
index 000000000000..a2a9c08e7963
--- /dev/null
+++ b/security/pam_krb5/Makefile
@@ -0,0 +1,56 @@
+# Ports collection Makefile for: pam_krb5
+# Date created: 11/03/2000
+# Whom: nectar@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= pam_krb5
+PORTVERSION= 1.0.3
+CATEGORIES= security
+MASTER_SITES= http://www.komquats.com/distfiles/
+
+MAINTAINER= cy@FreeBSD.org
+
+MAN8= pam_krb5.8
+
+USE_BZIP2= yes
+USE_PERL5= yes
+GNU_CONFIGURE= yes
+
+.if defined(PACKAGE_BUILDING)
+KRB5_IMPL= mit
+.endif
+
+.if defined(KRB5_IMPL) && ${KRB5_IMPL} == heimdal
+LIB_DEPENDS= krb5.18:${PORTSDIR}/security/heimdal
+.if defined(HEIMDAL_HOME)
+KRB5_DIR?= ${HEIMDAL_HOME}
+.endif
+.elif defined(KRB5_IMPL) && ${KRB5_IMPL} == mit
+LIB_DEPENDS= krb5.3:${PORTSDIR}/security/krb5
+.if defined(KRB5_HOME)
+KRB5_DIR?= ${KRB5_HOME}
+.endif
+.else
+BROKEN= You must define KRB5_IMPL to be \"mit\" or \"heimdal\"
+.endif
+
+.if defined(PREFIX)
+MANDIR= ${PREFIX}/man
+.else
+PREFIX= ${DESTDIR}/usr
+MANPREFIX= ${DESTDIR}/usr/share
+MANDIR= ${PREFIX}/share/man
+.endif
+KRB5_DIR?= ${LOCALBASE}
+CONFIGURE_ENV= CFLAGS="${CFLAGS}"
+CONFIGURE_ARGS= --with-krb5="${KRB5_DIR}" \
+ --with-pamdir="${PREFIX}/lib" \
+ --with-man-sect=8 \
+ --mandir=${MANDIR}
+
+post-install:
+ cd ${WRKSRC} && ${MAKE} install-man
+
+.include <bsd.port.mk>