aboutsummaryrefslogtreecommitdiff
path: root/security/pear-Crypt_CBC/Makefile
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2003-01-30 09:50:18 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2003-01-30 09:50:18 +0000
commit2f54b7c5a28ba38baa70e6fd390b2e26c29a04d3 (patch)
tree9e85cb93275015116a6e0543e61e24a31f056259 /security/pear-Crypt_CBC/Makefile
parent294a39e112306d7a5228380e34d231799e472834 (diff)
downloadports-2f54b7c5a28ba38baa70e6fd390b2e26c29a04d3.tar.gz
ports-2f54b7c5a28ba38baa70e6fd390b2e26c29a04d3.zip
Add security/pear-Crypt_CBC:
PEAR class to emulate Perl's Crypt::CBC module PR: ports/47418 Submitted by: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=74263
Diffstat (limited to 'security/pear-Crypt_CBC/Makefile')
-rw-r--r--security/pear-Crypt_CBC/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/security/pear-Crypt_CBC/Makefile b/security/pear-Crypt_CBC/Makefile
new file mode 100644
index 000000000000..f8d16af22b09
--- /dev/null
+++ b/security/pear-Crypt_CBC/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: pear-Crypt_CBC
+# Date created: 28 November 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt_CBC
+PORTVERSION= 0.3
+CATEGORIES= security www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+NO_BUILD= yes
+
+LPHP_LIB= lib/php
+PEARDIR= ${LOCALBASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${MKDIR} ${PEARDIR}/Crypt
+ @${CP} -Rp ${WRKSRC}/CBC.php ${PEARDIR}/Crypt
+#Note: HCEMD5.php is still needed for IMP 3.1,
+# but should be removed with the next releases.
+ @${CP} -p ${FILESDIR}/Crypt_HCEMD5.php ${PEARDIR}/Crypt/HCEMD5.php
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Crypt
+
+.include <bsd.port.mk>