aboutsummaryrefslogtreecommitdiff
path: root/security/pear-LiveUser
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-03-08 19:48:41 +0000
commita1993564e04f29ecbaa05be740547c8677d423cd (patch)
treea942b9de6ec3ced252f123bf8a905b18d685aa72 /security/pear-LiveUser
parent868fb29f23bfae4d55ab923ea34259adf63b4886 (diff)
downloadports-a1993564e04f29ecbaa05be740547c8677d423cd.tar.gz
ports-a1993564e04f29ecbaa05be740547c8677d423cd.zip
Introduce PHP flavors.
Ports using USES=php:phpize, php:ext, php:zend, and php:pecl are now flavored. They will automatically get flavors (php56, php70, php71, php72) depending of the versions they support (set with IGNORE_WITH_PHP). As a consequence, ports using USES=pear and USES=horde are also flavored. PR: 226242 Submitted by: mat Exp-run by: antoine Approved by: portmgr Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14208
Notes
Notes: svn path=/head/; revision=463917
Diffstat (limited to 'security/pear-LiveUser')
-rw-r--r--security/pear-LiveUser/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/security/pear-LiveUser/Makefile b/security/pear-LiveUser/Makefile
index 0dfdef96ff78..40fd732bf1dc 100644
--- a/security/pear-LiveUser/Makefile
+++ b/security/pear-LiveUser/Makefile
@@ -8,8 +8,8 @@ CATEGORIES= security www pear
MAINTAINER= joneum@FreeBSD.org
COMMENT= PEAR user authentication and permission management framework
-BUILD_DEPENDS= ${PEARDIR}/Event/Dispatcher.php:devel/pear-Event_Dispatcher
-RUN_DEPENDS= ${PEARDIR}/Event/Dispatcher.php:devel/pear-Event_Dispatcher
+BUILD_DEPENDS= ${PEARDIR}/Event/Dispatcher.php:devel/pear-Event_Dispatcher@${PHP_FLAVOR}
+RUN_DEPENDS= ${PEARDIR}/Event/Dispatcher.php:devel/pear-Event_Dispatcher@${PHP_FLAVOR}
PORTSCOUT= skipv:0.61
@@ -23,11 +23,11 @@ PEAR_LOG_DESC= PEAR::Log support
PEAR_XML_TREE_DESC= PEAR::XML_Tree support
PEAR_CRYPT_RC4_DESC= PEAR::Crypt_RC4 support
-PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB
-PEAR_MDB_RUN_DEPENDS= ${PEARDIR}/MDB.php:databases/pear-MDB
-PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:databases/pear-MDB2
-PEAR_LOG_RUN_DEPENDS= ${PEARDIR}/Log/null.php:sysutils/pear-Log
-PEAR_XML_TREE_RUN_DEPENDS= ${PEARDIR}/XML/Tree.php:devel/pear-XML_Tree
-PEAR_CRYPT_RC4_RUN_DEPENDS= ${PEARDIR}/Crypt/Rc4.php:security/pear-Crypt_RC4
+PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:databases/pear-DB@${PHP_FLAVOR}
+PEAR_MDB_RUN_DEPENDS= ${PEARDIR}/MDB.php:databases/pear-MDB@${PHP_FLAVOR}
+PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:databases/pear-MDB2@${PHP_FLAVOR}
+PEAR_LOG_RUN_DEPENDS= ${PEARDIR}/Log/null.php:sysutils/pear-Log@${PHP_FLAVOR}
+PEAR_XML_TREE_RUN_DEPENDS= ${PEARDIR}/XML/Tree.php:devel/pear-XML_Tree@${PHP_FLAVOR}
+PEAR_CRYPT_RC4_RUN_DEPENDS= ${PEARDIR}/Crypt/Rc4.php:security/pear-Crypt_RC4@${PHP_FLAVOR}
.include <bsd.port.mk>