aboutsummaryrefslogtreecommitdiff
path: root/security/pear-LiveUser_Admin/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-12-17 02:15:13 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-12-17 02:15:13 +0000
commit3bdf701a5c55426eb679205359bb384d7019a1a2 (patch)
tree2462f02d26b3d6c876b0b158f0a6aa557f06a219 /security/pear-LiveUser_Admin/Makefile
parent87b9f8cbd167accbbbbcf020b1dfed71e5f93278 (diff)
downloadports-3bdf701a5c55426eb679205359bb384d7019a1a2.tar.gz
ports-3bdf701a5c55426eb679205359bb384d7019a1a2.zip
Convert miwi's ports to new Options framework
While here fix some consistency in PEAR options name bumped revision of net/icpld and net/ipsumdump because IPV6 is now on Approved by: miwi (maintainer)
Notes
Notes: svn path=/head/; revision=309053
Diffstat (limited to 'security/pear-LiveUser_Admin/Makefile')
-rw-r--r--security/pear-LiveUser_Admin/Makefile36
1 files changed, 17 insertions, 19 deletions
diff --git a/security/pear-LiveUser_Admin/Makefile b/security/pear-LiveUser_Admin/Makefile
index 2174c279cd1f..052b01d80636 100644
--- a/security/pear-LiveUser_Admin/Makefile
+++ b/security/pear-LiveUser_Admin/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: pear-LiveUser_Admin
-# Date created: 25 January 2005
-# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
-#
+# Created by: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
# $FreeBSD$
-#
PORTNAME= LiveUser_Admin
PORTVERSION= 0.4.0
@@ -17,40 +13,42 @@ BUILD_DEPENDS= ${PEARDIR}/LiveUser.php:${PORTSDIR}/security/pear-LiveUser
RUN_DEPENDS= ${PEARDIR}/LiveUser.php:${PORTSDIR}/security/pear-LiveUser
LATEST_LINK= pear-LiveUser_Admin
-OPTIONS= PEAR_DB "PEAR::DB support" off \
- PEAR_MDB "PEAR::MDB support" off \
- PEAR_MDB2 "PEAR::MDB2 support" off \
- PEAR_LOG "PEAR::Log support" off \
- PEAR_XML_TREE "PEAR::XML_Tree support" off \
- PEAR_CRYPT_RC4 "PEAR::Crypt_RC4 support" off
+OPTIONS_DEFINE= PEAR_DB PEAR_MDB PEAR_MDB2 PEAR_LOG PEAR_XML_TREE PEAR_CRYPT_RC4
+
+PEAR_DB_DESC= PEAR::DB support
+PEAR_MDB_DESC= PEAR::MDB support
+PEAR_MDB2_DESC= PEAR::MDB2 support
+PEAR_LOG_DESC= PEAR::Log support
+PEAR_XML_TREE_DESC= PEAR::XML_Tree support
+PEAR_CRYPT_RC4_DESC= PEAR::Crypt_RC4 support
PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_PEAR_DB)
+.if ${PORT_OPTIONS:MPEAR_DB}
RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
.endif
-.if defined(WITH_PEAR_MDB)
+.if ${PORT_OPTIONS:MPEAR_MDB}
RUN_DEPENDS+= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB
.endif
-.if defined(WITH_PEAR_MDB2)
+.if ${PORT_OPTIONS:MPEAR_MDB2}
RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
.endif
-.if defined(WITH_PEAR_LOG)
+.if ${PORT_OPTIONS:MPEAR_LOG}
RUN_DEPENDS+= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
.endif
-.if defined(WITH_PEAR_XML_TREE)
+.if ${PORT_OPTIONS:MPEAR_XML_TREE}
RUN_DEPENDS+= ${PEARDIR}/XML/Tree.php:${PORTSDIR}/devel/pear-XML_Tree
.endif
-.if defined(WITH_PEAR_CRYPT_RC4)
+.if ${PORT_OPTIONS:MPEAR_CRYPT_RC4}
RUN_DEPENDS+= ${PEARDIR}/Crypt/Rc4.php:${PORTSDIR}/security/pear-Crypt_RC4
.endif
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>