aboutsummaryrefslogtreecommitdiff
path: root/security/pgpin
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2016-10-07 19:37:14 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2016-10-07 19:37:14 +0000
commitfb703cc276556aaf8e7bf25f3ff9f383c34fa390 (patch)
treef770605def5c32f1d9559729a33a1972b1f1d6c7 /security/pgpin
parent40b6e986f79e8e10ce9a122e5757ac33bd65a16b (diff)
downloadports-fb703cc276556aaf8e7bf25f3ff9f383c34fa390.tar.gz
ports-fb703cc276556aaf8e7bf25f3ff9f383c34fa390.zip
- move DOCS and make them an option
- update URL, MASTER_SITES - add framework for mips64 - add LICENSE
Notes
Notes: svn path=/head/; revision=423481
Diffstat (limited to 'security/pgpin')
-rw-r--r--security/pgpin/Makefile20
-rw-r--r--security/pgpin/files/patch-makefile10
-rw-r--r--security/pgpin/pkg-descr2
-rw-r--r--security/pgpin/pkg-plist6
4 files changed, 26 insertions, 12 deletions
diff --git a/security/pgpin/Makefile b/security/pgpin/Makefile
index 6290476a6314..a74fcf657fe7 100644
--- a/security/pgpin/Makefile
+++ b/security/pgpin/Makefile
@@ -2,13 +2,17 @@
PORTNAME= pgpin
PORTVERSION= 010323
+PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= LOCAL/dinoex
+MASTER_SITES= LOCAL/dinoex \
+ ftp://ftp.iks-jena.de/pub/mitarb/lutz/crypt/software/pgp/pgp263in/
DISTNAME= pgp263in${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= PGP International version - improved for use in IN-CA
+LICENSE= MIT
+
BROKEN_powerpc64= Does not build
USES= tar:tgz
@@ -17,14 +21,20 @@ MAKEFILE= makefile
ALL_TARGET= freebsd-${ARCH} OS_CFLAGS="${CFLAGS}"
PGPLIB= ${STAGEDIR}${PREFIX}/lib/pgpin
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pgp ${STAGEDIR}${PREFIX}/bin/pgpin
${INSTALL_MAN} ${WRKSRC}/../doc/pgp.1 ${STAGEDIR}${PREFIX}/man/man1/pgpin.1
- -${MKDIR} ${PGPLIB}
- ${INSTALL_DATA} ${FILESDIR}/CHANGES ${PGPLIB}/
- cd ${WRKSRC}/.. && \
- ${INSTALL_DATA} pgp.hlp doc/pgpdoc1.txt doc/pgpdoc2.txt ${PGPLIB}/
+ ${MKDIR} ${PGPLIB}
+ ${INSTALL_DATA} ${WRKSRC}/../pgp.hlp ${PGPLIB}/
${INSTALL_DATA} ${WRKSRC}/../language.txt ${PGPLIB}/language.txt.sample
${INSTALL_DATA} ${WRKSRC}/../config.txt ${PGPLIB}/config.txt.sample
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${FILESDIR}/CHANGES ${STAGEDIR}${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/../doc/pgpdoc1.txt \
+ ${WRKSRC}/../doc/pgpdoc2.txt ${STAGEDIR}${DOCSDIR}/
+.endif
.include <bsd.port.mk>
diff --git a/security/pgpin/files/patch-makefile b/security/pgpin/files/patch-makefile
index 7692c1143631..09586927e062 100644
--- a/security/pgpin/files/patch-makefile
+++ b/security/pgpin/files/patch-makefile
@@ -1,5 +1,5 @@
--- makefile.orig 2001-03-23 11:44:58.000000000 +0100
-+++ makefile 2015-06-09 05:49:07.000000000 +0200
++++ makefile 2016-10-07 07:05:13.258216000 +0200
@@ -50,15 +50,15 @@
# -DUSE_SELECT to use select() system call
# -DUSE_NBIO to use non-blocking read()
@@ -27,11 +27,11 @@
@echo " apollo-gcc, atari,aux(*), aux-gcc, bsd, bsdgcc, convexos,"
- @echo " dgux, djgpp, encore, freebsd, hpux-68k(*), hpux-68k-ansi,"
+ @echo " dgux, djgpp, encore, hpux-68k(*), hpux-68k-ansi,"
-+ @echo " freebsd-{alpha,i386,sparc64,ia64,amd64,powerpc,armv6,mips},"
++ @echo " freebsd-{alpha,i386,sparc64,ia64,amd64,powerpc,armv6,mips,mips64},"
@echo " hpux-68k-gcc, hpux-pa(*), hpux-pa-ansi, hpux-pa-gcc, hpux9-pa-ansi,"
@echo " irix, irix_asm, isc, isc_asm, linux, linux-aout, linux-68k,"
@echo " machten, mach_386, mips-ultrix, netbsd, netbsd_68k, newsasm,"
-@@ -175,11 +176,42 @@
+@@ -175,11 +176,46 @@
$(MAKE) all CC=gcc LD=gcc \
CFLAGS="$(RSAINCDIR) -O2 -DHIGHFIRST -DUNIX -DPORTABLE -DIDEA32"
@@ -72,6 +72,10 @@
+ $(MAKE) all LD="$(CC) -s" \
+ CFLAGS="$(RSAINCDIR) $(OS_CFLAGS) -DPORTABLE -DUNIX -DIDEA32 \
+ -DMAX_NAMELEN=255 -DMPORTABLE"
++freebsd-mips64:
++ $(MAKE) all LD="$(CC) -s" \
++ CFLAGS="$(RSAINCDIR) $(OS_CFLAGS) -DPORTABLE -DUNIX -DIDEA32 \
++ -DMAX_NAMELEN=255 -DMPORTABLE"
+
386bsd:
$(MAKE) all CC=gcc LD=gcc OBJS_EXT="_80386.o _zmatch.o" \
diff --git a/security/pgpin/pkg-descr b/security/pgpin/pkg-descr
index c672fca7fbb1..e39dec05bfd5 100644
--- a/security/pgpin/pkg-descr
+++ b/security/pgpin/pkg-descr
@@ -11,4 +11,4 @@ Contributors:
Lutz Donnerhacke for the pgp2.6.3in development.
Ingmar Camphausen, Thomas Roessler, a.o. for extensive testing.
-FTP: ftp://ftp.fu-berlin.de/doc/IN/IN-CA/pgp/pgp263in/files/pgp263in.changes
+WWW: http://www.pgpi.org/
diff --git a/security/pgpin/pkg-plist b/security/pgpin/pkg-plist
index 68762e156a02..cc11b76269c8 100644
--- a/security/pgpin/pkg-plist
+++ b/security/pgpin/pkg-plist
@@ -1,8 +1,8 @@
bin/pgpin
-lib/pgpin/CHANGES
lib/pgpin/pgp.hlp
-lib/pgpin/pgpdoc1.txt
-lib/pgpin/pgpdoc2.txt
@sample lib/pgpin/language.txt.sample
@sample lib/pgpin/config.txt.sample
man/man1/pgpin.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/pgpdoc1.txt
+%%PORTDOCS%%%%DOCSDIR%%/pgpdoc2.txt