aboutsummaryrefslogtreecommitdiff
path: root/security/php71-hash
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-01-24 11:54:20 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-01-24 11:54:20 +0000
commitdb021968e3411b659e079e540742896abe4193f1 (patch)
treead7f282ff1e254cc6c54bfc24d23efee0af4d12e /security/php71-hash
parent93028a155ae531c7c9a6c723a6d465b49a90e9df (diff)
downloadports-db021968e3411b659e079e540742896abe4193f1.tar.gz
ports-db021968e3411b659e079e540742896abe4193f1.zip
Add PHP 7.1
Thanks to: mat, pi, ale, martin@waschbuesch.de and franco@opnsense.org
Notes
Notes: svn path=/head/; revision=432324
Diffstat (limited to 'security/php71-hash')
-rw-r--r--security/php71-hash/Makefile9
-rw-r--r--security/php71-hash/files/patch-php__hash__sha3.h11
2 files changed, 20 insertions, 0 deletions
diff --git a/security/php71-hash/Makefile b/security/php71-hash/Makefile
new file mode 100644
index 000000000000..ee41b199dc0b
--- /dev/null
+++ b/security/php71-hash/Makefile
@@ -0,0 +1,9 @@
+# $FreeBSD$
+
+CATEGORIES= security
+
+MASTERDIR= ${.CURDIR}/../../lang/php71
+
+PKGNAMESUFFIX= -hash
+
+.include "${MASTERDIR}/Makefile"
diff --git a/security/php71-hash/files/patch-php__hash__sha3.h b/security/php71-hash/files/patch-php__hash__sha3.h
new file mode 100644
index 000000000000..5c3f2936e690
--- /dev/null
+++ b/security/php71-hash/files/patch-php__hash__sha3.h
@@ -0,0 +1,11 @@
+--- php_hash_sha3.h.orig 2016-11-09 03:34:27 UTC
++++ php_hash_sha3.h
+@@ -20,7 +20,7 @@
+ #define PHP_HASH_SHA3_H
+
+ #include "php.h"
+-#include "ext/hash/php_hash.h"
++#include "php_hash.h"
+
+ typedef struct {
+ unsigned char state[200]; // 5 * 5 * sizeof(uint64)