aboutsummaryrefslogtreecommitdiff
path: root/security/pkcs11-tools
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-20 18:26:59 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-20 18:31:36 +0000
commit97b9d2f58f38dc0be07175b8de4ebb616d4ddacd (patch)
tree21c938e2539665798bba4cbc9cca0f3941e890a5 /security/pkcs11-tools
parent6b460ab1a9d978a39708ed330566fbb1fc3d8d70 (diff)
downloadports-97b9d2f58f38dc0be07175b8de4ebb616d4ddacd.tar.gz
ports-97b9d2f58f38dc0be07175b8de4ebb616d4ddacd.zip
security/pkcs11-tools: Broken on 11 with base OpenSSL due to version being too old
Also add comment about the workaround for missing symbols in /usr/lib/libcrypto.so. Reported by: fallout
Diffstat (limited to 'security/pkcs11-tools')
-rw-r--r--security/pkcs11-tools/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/security/pkcs11-tools/Makefile b/security/pkcs11-tools/Makefile
index f3b9c8c89813..cc911ba91321 100644
--- a/security/pkcs11-tools/Makefile
+++ b/security/pkcs11-tools/Makefile
@@ -8,7 +8,9 @@ COMMENT= Tools for managing PKCS11 cryptographic tokens
LICENSE= APACHE20
-BROKEN_SSL= libressl
+BROKEN_SSL_11= base
+BROKEN_SSL_11_REASON_base= OpenSSL version is too old, lacks symbols: error: use of undeclared identifier 'EVP_PKEY_X25519', etc.
+BROKEN_SSL= libressl
BROKEN_SSL_REASON_libressl= error: use of undeclared identifier 'EVP_PKEY_X25519' (LibreSSL has no support for Edwards curves)
BUILD_DEPENDS= autoconf>0:devel/autoconf \
@@ -28,6 +30,7 @@ GNU_CONFIGURE= yes
MAKE_ENV= LIBCRYPTO_RPATH=${OPENSSLBASE}/lib
+# workaround for Bug#255277:
LDFLAGS+= ${OPENSSLBASE}/lib/libcrypto.a # -lcrypto # fails to find symbol in the shared library: ld: error: undefined symbol: EVP_PKEY_meth_get_digestsign
INSTALL_TARGET= install-strip