aboutsummaryrefslogtreecommitdiff
path: root/security/putty
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-04-30 15:17:39 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-04-30 15:17:39 +0000
commitc725900c4bf6437c7fe34fdb6f4d5c2e94bc6976 (patch)
treecd407e858f042d144b73685530ab15ee1b5a4016 /security/putty
parent2faf2481a55b0cf4fe3948258a69a640c4785307 (diff)
downloadports-c725900c4bf6437c7fe34fdb6f4d5c2e94bc6976.tar.gz
ports-c725900c4bf6437c7fe34fdb6f4d5c2e94bc6976.zip
- Update to 0.58
- Assign maintainership PR: 80460 Submitted by: Renato Botelho <freebsd@galle.com.br>
Notes
Notes: svn path=/head/; revision=134409
Diffstat (limited to 'security/putty')
-rw-r--r--security/putty/Makefile9
-rw-r--r--security/putty/distinfo4
-rw-r--r--security/putty/files/patch-Makefile.gtk33
-rw-r--r--security/putty/files/patch-pty.c35
-rw-r--r--security/putty/files/patch-uxnet.c6
5 files changed, 29 insertions, 58 deletions
diff --git a/security/putty/Makefile b/security/putty/Makefile
index ec21f631fed5..a86a2578f0dc 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= putty
-PORTVERSION= 0.57
+PORTVERSION= 0.58
CATEGORIES= security ipv6
MASTER_SITES= http://the.earth.li/~sgtatham/putty/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= freebsd@galle.com.br
COMMENT= Secure shell and telnet client
USE_GMAKE= yes
@@ -19,6 +19,7 @@ USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
MAKEFILE= Makefile.gtk
CFLAGS+= -DBSD_PTYS -DOMIT_UTMP
+
.ifndef WITHOUT_IPV6
CFLAGS+= -DIPV6
.endif
@@ -34,7 +35,9 @@ MAKE_ENV+= PUTTY_WITH_GTK=yes
.endif
post-patch:
- ${REINPLACE_CMD} -e 's,gtk-config,${GTK_CONFIG},' ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's,gtk-config,${GTK_CONFIG},; \
+ s,prefix=/usr/local,prefix=${PREFIX},' \
+ ${WRKSRC}/${MAKEFILE}
.include <bsd.port.pre.mk>
diff --git a/security/putty/distinfo b/security/putty/distinfo
index 27f97e8348af..87a0df18d1de 100644
--- a/security/putty/distinfo
+++ b/security/putty/distinfo
@@ -1,2 +1,2 @@
-MD5 (putty-0.57.tar.gz) = 0fc816093980246f6400693fe6146280
-SIZE (putty-0.57.tar.gz) = 1319513
+MD5 (putty-0.58.tar.gz) = ffb78a7db7e4802896189b2112714a9f
+SIZE (putty-0.58.tar.gz) = 1567268
diff --git a/security/putty/files/patch-Makefile.gtk b/security/putty/files/patch-Makefile.gtk
index 1aff4c1f2c40..df4e80fefbfe 100644
--- a/security/putty/files/patch-Makefile.gtk
+++ b/security/putty/files/patch-Makefile.gtk
@@ -1,17 +1,17 @@
---- Makefile.gtk.orig Tue Aug 3 19:42:46 2004
-+++ Makefile.gtk Wed Aug 4 09:58:44 2004
-@@ -80,7 +80,7 @@
+--- Makefile.gtk.orig Fri Apr 29 13:01:07 2005
++++ Makefile.gtk Fri Apr 29 13:06:39 2005
+@@ -82,7 +82,7 @@
# TOOLPATH = /opt/gcc/bin
CC = $(TOOLPATH)cc
--CFLAGS = -O2 -Wall -Werror -g -I.././ -I../charset/ -I../unix/ -I../mac/ \
-+CFLAGS += -O2 -Wall -g -I.././ -I../charset/ -I../unix/ -I../mac/ \
- `gtk-config --cflags`
+-CFLAGS = -O2 -Wall -Werror -g -I.././ -I../charset/ -I../windows/ -I../unix/ \
++CFLAGS += -O2 -Wall -g -I.././ -I../charset/ -I../windows/ -I../unix/ \
+ -I../mac/ -I../macosx/ `gtk-config --cflags`
XLDFLAGS = `gtk-config --libs`
ULDFLAGS =#
-@@ -98,7 +98,11 @@
- %.o:
- $(CC) $(COMPAT) $(FWHACK) $(XFLAGS) $(CFLAGS) -c $<
+@@ -99,7 +99,11 @@
+ .SUFFIXES:
+
+ifdef PUTTY_WITH_GTK
all: plink pscp psftp pterm putty puttygen puttytel
@@ -19,23 +19,26 @@
+all: plink pscp psftp
+endif
- plink: be_all.o cmdline.o ldisc.o logging.o misc.o portfwd.o proxy.o raw.o \
- rlogin.o settings.o signal.o ssh.o sshaes.o sshblowf.o \
-@@ -616,7 +620,7 @@
+ plink: be_all.o cmdline.o cproxy.o ldisc.o logging.o misc.o pinger.o \
+ portfwd.o proxy.o raw.o rlogin.o settings.o ssh.o sshaes.o \
+@@ -828,7 +832,7 @@
version.o: FORCE;
FORCE:
- if test -z "$(VER)" && (cd ..; md5sum -c manifest); then \
+ if test -z "$(VER)" ; then \
- $(CC) $(COMPAT) $(FWHACK) $(XFLAGS) $(CFLAGS) `cat ../version.def` -c ../version.c; \
+ $(CC) $(COMPAT) $(XFLAGS) $(CFLAGS) `cat ../version.def` -c ../version.c; \
else \
- $(CC) $(COMPAT) $(FWHACK) $(XFLAGS) $(CFLAGS) $(VER) -c ../version.c; \
-@@ -625,17 +629,21 @@
+ $(CC) $(COMPAT) $(XFLAGS) $(CFLAGS) $(VER) -c ../version.c; \
+@@ -837,6 +841,7 @@
$(INSTALL_PROGRAM) -m 755 plink $(DESTDIR)$(bindir)/plink
$(INSTALL_PROGRAM) -m 755 pscp $(DESTDIR)$(bindir)/pscp
$(INSTALL_PROGRAM) -m 755 psftp $(DESTDIR)$(bindir)/psftp
+ifdef PUTTY_WITH_GTK
$(INSTALL_PROGRAM) -m 755 pterm $(DESTDIR)$(bindir)/pterm
+ if test -n "$(UTMP_GROUP)"; then \
+ chgrp $(UTMP_GROUP) $(DESTDIR)$(bindir)/pterm && \
+@@ -848,13 +853,16 @@
$(INSTALL_PROGRAM) -m 755 putty $(DESTDIR)$(bindir)/putty
$(INSTALL_PROGRAM) -m 755 puttygen $(DESTDIR)$(bindir)/puttygen
$(INSTALL_PROGRAM) -m 755 puttytel $(DESTDIR)$(bindir)/puttytel
diff --git a/security/putty/files/patch-pty.c b/security/putty/files/patch-pty.c
deleted file mode 100644
index 2e35c8334b07..000000000000
--- a/security/putty/files/patch-pty.c
+++ /dev/null
@@ -1,35 +0,0 @@
---- pty.c.orig Sun May 11 14:28:53 2003
-+++ pty.c Fri Feb 13 15:06:26 2004
-@@ -14,7 +14,9 @@
- #define _XOPEN_SOURCE
- #define _XOPEN_SOURCE_EXTENDED
- #define _GNU_SOURCE
-+#ifndef __FreeBSD__
- #include <features.h>
-+#endif
-
- #include <stdio.h>
- #include <stdlib.h>
-@@ -32,6 +34,10 @@
- #include <sys/ioctl.h>
- #include <errno.h>
-
-+#ifdef __FreeBSD__
-+#include <sys/stat.h>
-+#endif
-+
- #include "putty.h"
-
- #ifndef FALSE
-@@ -567,9 +573,9 @@
- ioctl(slavefd, TIOCSCTTY, 1);
- pgrp = getpid();
- tcsetpgrp(slavefd, pgrp);
-- setpgrp();
-+ setpgrp( pgrp, -1 );
- close(open(pty_name, O_WRONLY, 0));
-- setpgrp();
-+ setpgrp( pgrp, -1 );
- /* Close everything _else_, for tidiness. */
- for (i = 3; i < 1024; i++)
- close(i);
diff --git a/security/putty/files/patch-uxnet.c b/security/putty/files/patch-uxnet.c
index e3cfc949c4b1..f7971978077c 100644
--- a/security/putty/files/patch-uxnet.c
+++ b/security/putty/files/patch-uxnet.c
@@ -1,5 +1,5 @@
---- uxnet.c.orig Tue Feb 3 15:47:43 2004
-+++ uxnet.c Fri Feb 13 14:19:00 2004
+--- uxnet.c.orig Fri Apr 29 12:48:56 2005
++++ uxnet.c Fri Apr 29 12:49:29 2005
@@ -11,8 +11,13 @@
#include <sys/types.h>
#include <sys/socket.h>
@@ -13,4 +13,4 @@
+#endif
#include <netinet/tcp.h>
#include <netdb.h>
-
+ #include <sys/un.h>