aboutsummaryrefslogtreecommitdiff
path: root/security/pwned-check
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2022-07-27 12:50:33 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2022-07-27 12:50:33 +0000
commit42e904d02c6695123d22aaeddfccb3d0863a2831 (patch)
tree386936009e1db0dfc520b91f7bea57a43ff6d25e /security/pwned-check
parent7f7b639967bf2ed951fe80e5db9789e29ed5e5e8 (diff)
downloadports-42e904d02c6695123d22aaeddfccb3d0863a2831.tar.gz
ports-42e904d02c6695123d22aaeddfccb3d0863a2831.zip
security/pwned-check: use pkg-message to show message on remove
Diffstat (limited to 'security/pwned-check')
-rw-r--r--security/pwned-check/Makefile3
-rw-r--r--security/pwned-check/files/pkg-message.in12
-rw-r--r--security/pwned-check/pkg-deinstall15
3 files changed, 15 insertions, 15 deletions
diff --git a/security/pwned-check/Makefile b/security/pwned-check/Makefile
index 19f0878214d7..72057c2e2450 100644
--- a/security/pwned-check/Makefile
+++ b/security/pwned-check/Makefile
@@ -11,6 +11,9 @@ COMMENT= Check whether password is known to have been exposed in a data breach
LICENSE= BSD2CLAUSE
+SUB_FILES= pkg-message
+SUB_LIST= PORTNAME=${PORTNAME}
+
NO_ARCH= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/src
diff --git a/security/pwned-check/files/pkg-message.in b/security/pwned-check/files/pkg-message.in
index e12280d612c2..4a11c095cbc6 100644
--- a/security/pwned-check/files/pkg-message.in
+++ b/security/pwned-check/files/pkg-message.in
@@ -13,5 +13,17 @@ The installation procedure will fetch 6 GB of compressed data and will
temporarily need 18 GB of free space in that directory and 13 GB when
the installation is complete.
EOM
+},
+{ type : remove
+ message: <<EOM
+------------------------------------------------------------------------------
+
+If you are no longer using the %%PORTNAME%% port, then manually delete
+the following directory and all its contents:
+
+ /var/db/%%PORTNAME%%
+
+------------------------------------------------------------------------------
+EOM
}
]
diff --git a/security/pwned-check/pkg-deinstall b/security/pwned-check/pkg-deinstall
deleted file mode 100644
index 0d1e7d2dba0e..000000000000
--- a/security/pwned-check/pkg-deinstall
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh
-
-PORTNAME=${1%-*}
-
-[ "$2" = DEINSTALL ] && cat <<***EOM
-------------------------------------------------------------------------------
-
-If you are no longer using the $PORTNAME port, then manually delete
-the following directory and all its contents:
-
- /var/db/$PORTNAME
-
-------------------------------------------------------------------------------
-***EOM
-exit 0