aboutsummaryrefslogtreecommitdiff
path: root/security/py-azure-keyvault-keys
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-17 17:51:30 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-02-17 17:51:30 +0000
commitefbf2c233447572251bf192e68cafc5f7826e879 (patch)
treed24c484c589d5a6b15a64dcfa4080ffdcc2829a0 /security/py-azure-keyvault-keys
parent64edb083c7e698ee451f903bf19142540844496c (diff)
downloadports-efbf2c233447572251bf192e68cafc5f7826e879.tar.gz
ports-efbf2c233447572251bf192e68cafc5f7826e879.zip
Add py-azure-keyvault-keys 4.3.1
Azure Key Vault Keys Client Library provides cryptographic key management. It can be used to create, store, and control access to the keys used to encrypt your data. WWW: https://github.com/Azure/azure-sdk-for-python/tree/master/sdk/keyvault/azure-keyvault-keys
Notes
Notes: svn path=/head/; revision=565536
Diffstat (limited to 'security/py-azure-keyvault-keys')
-rw-r--r--security/py-azure-keyvault-keys/Makefile25
-rw-r--r--security/py-azure-keyvault-keys/distinfo3
-rw-r--r--security/py-azure-keyvault-keys/pkg-descr5
3 files changed, 33 insertions, 0 deletions
diff --git a/security/py-azure-keyvault-keys/Makefile b/security/py-azure-keyvault-keys/Makefile
new file mode 100644
index 000000000000..43783ebc5dc1
--- /dev/null
+++ b/security/py-azure-keyvault-keys/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= azure-keyvault-keys
+PORTVERSION= 4.3.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Microsoft Azure Key Vault Keys Client Library for Python
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}azure-common>=1.1<2:www/py-azure-common@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}azure-core>=1.7.0<2.0.0:devel/py-azure-core@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=2.1.4:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}msrest>=0.6.0:net-mgmt/py-msrest@${PY_FLAVOR}
+
+USES= python:3.6+ zip
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-azure-keyvault-keys/distinfo b/security/py-azure-keyvault-keys/distinfo
new file mode 100644
index 000000000000..e3e14b19cc07
--- /dev/null
+++ b/security/py-azure-keyvault-keys/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1613478307
+SHA256 (azure-keyvault-keys-4.3.1.zip) = fbf67bca913ebf68b9075ee9d2e2b899dc3c7892cc40abfe1b08220a382f6ed9
+SIZE (azure-keyvault-keys-4.3.1.zip) = 343485
diff --git a/security/py-azure-keyvault-keys/pkg-descr b/security/py-azure-keyvault-keys/pkg-descr
new file mode 100644
index 000000000000..bf4f6feea16b
--- /dev/null
+++ b/security/py-azure-keyvault-keys/pkg-descr
@@ -0,0 +1,5 @@
+Azure Key Vault Keys Client Library provides cryptographic key management. It
+can be used to create, store, and control access to the keys used to encrypt
+your data.
+
+WWW: https://github.com/Azure/azure-sdk-for-python/tree/master/sdk/keyvault/azure-keyvault-keys