aboutsummaryrefslogtreecommitdiff
path: root/security/py-btchip-python
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2017-11-07 20:34:37 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2017-11-07 20:34:37 +0000
commitded2188719f088681d04b44630447d6275bab99f (patch)
tree4e48e38c8b5c89d037ac620d812c06aad5940759 /security/py-btchip-python
parent6d690090f3df7bef437bef6cac7e014c91b91fe6 (diff)
downloadports-ded2188719f088681d04b44630447d6275bab99f.tar.gz
ports-ded2188719f088681d04b44630447d6275bab99f.zip
- Rename securitypy-btchip to security/py-btchip-python to reflect official
Python modules naming scheme [1]. - Explain in MOVED why the port was renamed - Update security/py-btchip-python to 0.1.22 - Update dependency of finance/electrum Notified by: koobs [1]
Notes
Notes: svn path=/head/; revision=453674
Diffstat (limited to 'security/py-btchip-python')
-rw-r--r--security/py-btchip-python/Makefile27
-rw-r--r--security/py-btchip-python/distinfo3
-rw-r--r--security/py-btchip-python/pkg-descr3
3 files changed, 33 insertions, 0 deletions
diff --git a/security/py-btchip-python/Makefile b/security/py-btchip-python/Makefile
new file mode 100644
index 000000000000..9bbccf05d39b
--- /dev/null
+++ b/security/py-btchip-python/Makefile
@@ -0,0 +1,27 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= btchip-python
+PORTVERSION= 0.1.22
+DISTVERSIONPREFIX= v
+CATEGORIES= security python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Python communication library for Ledger Hardware Wallet
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mnemonic>=0:security/py-mnemonic \
+ ${PYTHON_PKGNAMEPREFIX}pyscard>0:security/py-pyscard \
+ ${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py-ecdsa \
+ ${PYTHON_PKGNAMEPREFIX}hidapi>=0:comms/py-hidapi
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+GH_ACCOUNT= LedgerHQ
+
+.include <bsd.port.mk>
diff --git a/security/py-btchip-python/distinfo b/security/py-btchip-python/distinfo
new file mode 100644
index 000000000000..6e5ba8d7f789
--- /dev/null
+++ b/security/py-btchip-python/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1510083234
+SHA256 (LedgerHQ-btchip-python-v0.1.22_GH0.tar.gz) = 6c1eef50fc151f4f96a06d184f200c801221c00978b99652c3728ab94966642a
+SIZE (LedgerHQ-btchip-python-v0.1.22_GH0.tar.gz) = 33174
diff --git a/security/py-btchip-python/pkg-descr b/security/py-btchip-python/pkg-descr
new file mode 100644
index 000000000000..ff8ecdcd643e
--- /dev/null
+++ b/security/py-btchip-python/pkg-descr
@@ -0,0 +1,3 @@
+Python communication library for Ledger Hardware Wallet.
+
+WWW: https://github.com/LedgerHQ/btchip-python