aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot-dns-dnsimple
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-02-22 14:30:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-02-22 14:30:30 +0000
commit31501d9bc6597ec66da3145d5943bc0c7baf9548 (patch)
tree70bf1bf0dc3182a77ab1108c127335061096208f /security/py-certbot-dns-dnsimple
parentfb8168fbeb87ba4d961afea34a56a869d0f84061 (diff)
downloadports-31501d9bc6597ec66da3145d5943bc0c7baf9548.tar.gz
ports-31501d9bc6597ec66da3145d5943bc0c7baf9548.zip
Add py-certbot-dns-dnsimple, DNSimple DNS Authenticator for py-certbot.
Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14262
Notes
Notes: svn path=/head/; revision=462602
Diffstat (limited to 'security/py-certbot-dns-dnsimple')
-rw-r--r--security/py-certbot-dns-dnsimple/Makefile31
-rw-r--r--security/py-certbot-dns-dnsimple/distinfo3
-rw-r--r--security/py-certbot-dns-dnsimple/pkg-descr3
3 files changed, 37 insertions, 0 deletions
diff --git a/security/py-certbot-dns-dnsimple/Makefile b/security/py-certbot-dns-dnsimple/Makefile
new file mode 100644
index 000000000000..76e9cb6f137f
--- /dev/null
+++ b/security/py-certbot-dns-dnsimple/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= certbot-dns-dnsimple
+PORTVERSION= ${ACME_VERSION}
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= DNSimple DNS Authenticator plugin for Certbot
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION}:security/py-acme@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION}:security/py-certbot@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dns-lexicon>0:dns/py-dns-lexicon@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${FLAVOR}
+
+.include "${.CURDIR}/../py-acme/version.mk"
+.include <bsd.port.mk>
diff --git a/security/py-certbot-dns-dnsimple/distinfo b/security/py-certbot-dns-dnsimple/distinfo
new file mode 100644
index 000000000000..37583391ad1b
--- /dev/null
+++ b/security/py-certbot-dns-dnsimple/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518084700
+SHA256 (certbot-dns-dnsimple-0.21.1.tar.gz) = a6066bad1b7b610fff640dbabaa98545d7d5328946318f7dc50f3773c4358f16
+SIZE (certbot-dns-dnsimple-0.21.1.tar.gz) = 11431
diff --git a/security/py-certbot-dns-dnsimple/pkg-descr b/security/py-certbot-dns-dnsimple/pkg-descr
new file mode 100644
index 000000000000..76acc481798f
--- /dev/null
+++ b/security/py-certbot-dns-dnsimple/pkg-descr
@@ -0,0 +1,3 @@
+This is the DNSimple DNS Authenticator plugin for Certbot (security/py-certbot).
+
+WWW: https://github.com/certbot/certbot