aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot-dns-route53
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-02-22 14:31:10 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-02-22 14:31:10 +0000
commitebd6a05b895f67f3d368e3fbd46aa0aa3f4d55bb (patch)
tree314f57eb6f8696927331cac66225b6267245013e /security/py-certbot-dns-route53
parentccf461f0142939dc84aa5b04c19068a693ca969d (diff)
downloadports-ebd6a05b895f67f3d368e3fbd46aa0aa3f4d55bb.tar.gz
ports-ebd6a05b895f67f3d368e3fbd46aa0aa3f4d55bb.zip
Add py-certbot-dns-route53, Route53 DNS Authenticator for py-certbot.
Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14262
Notes
Notes: svn path=/head/; revision=462608
Diffstat (limited to 'security/py-certbot-dns-route53')
-rw-r--r--security/py-certbot-dns-route53/Makefile26
-rw-r--r--security/py-certbot-dns-route53/distinfo3
-rw-r--r--security/py-certbot-dns-route53/pkg-descr3
3 files changed, 32 insertions, 0 deletions
diff --git a/security/py-certbot-dns-route53/Makefile b/security/py-certbot-dns-route53/Makefile
new file mode 100644
index 000000000000..2bf1e6085d12
--- /dev/null
+++ b/security/py-certbot-dns-route53/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= certbot-dns-route53
+PORTVERSION= ${ACME_VERSION}
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Route53 DNS Authenticator plugin for Certbot
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION}:security/py-acme@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION}:security/py-certbot@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}boto3>0:www/py-boto3@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include "${.CURDIR}/../py-acme/version.mk"
+.include <bsd.port.mk>
diff --git a/security/py-certbot-dns-route53/distinfo b/security/py-certbot-dns-route53/distinfo
new file mode 100644
index 000000000000..a7acde0fa69f
--- /dev/null
+++ b/security/py-certbot-dns-route53/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518087204
+SHA256 (certbot-dns-route53-0.21.1.tar.gz) = 88fef0422dcdd917e1d3d9be2ee1eb41187c50062ed4df98cd0ef2584fe58828
+SIZE (certbot-dns-route53-0.21.1.tar.gz) = 13893
diff --git a/security/py-certbot-dns-route53/pkg-descr b/security/py-certbot-dns-route53/pkg-descr
new file mode 100644
index 000000000000..80757127ac5f
--- /dev/null
+++ b/security/py-certbot-dns-route53/pkg-descr
@@ -0,0 +1,3 @@
+This is the Route53 DNS Authenticator plugin for Certbot (security/py-certbot).
+
+WWW: https://github.com/certbot/certbot