aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot/Makefile
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-06-27 20:57:40 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-06-27 20:57:40 +0000
commit34565269b5b79e8acc99bc84ff9e9f0124ce4f36 (patch)
tree1f06ec46a064d5c0d6ae9a3c07f8a0190422b3e3 /security/py-certbot/Makefile
parent5bb2d563b602c709464db1de631d015be01b50b0 (diff)
downloadports-34565269b5b79e8acc99bc84ff9e9f0124ce4f36.tar.gz
ports-34565269b5b79e8acc99bc84ff9e9f0124ce4f36.zip
security/py-certbot: Add man pages, Fix Concurrency
PR: 235701 Submitted by: Walter Schwarzenfeld <w.schwarzenfeld@utanet.at> Reported by: freebsd@dreamchaser.org Approved by: python (with hat)
Notes
Notes: svn path=/head/; revision=540635
Diffstat (limited to 'security/py-certbot/Makefile')
-rw-r--r--security/py-certbot/Makefile28
1 files changed, 26 insertions, 2 deletions
diff --git a/security/py-certbot/Makefile b/security/py-certbot/Makefile
index 5ae6d5f3ff27..3e8b3781504d 100644
--- a/security/py-certbot/Makefile
+++ b/security/py-certbot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= certbot
PORTVERSION= ${ACME_VERSION}
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
@@ -34,17 +35,40 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
SUB_FILES= 500.certbot
-PLIST_FILES= etc/periodic/weekly/500.certbot
+PLIST_FILES= etc/periodic/weekly/500.certbot-${PYTHON_VER}
+SUB_LIST= PYTHON_VER=${PYTHON_VER}
+
+OPTIONS_DEFINE= MANPAGES
+OPTIONS_DEFAULT= MANPAGES
+
+MANPAGES_BUILD_DEPENDS= ${RUN_DEPENDS} \
+ ${PY_SPHINX} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}repoze.sphinx.autointerface>0:devel/py-repoze.sphinx.autointerface@${PY_FLAVOR} \
+
+MANPAGES_PLIST_FILES= share/man/man1/certbot.1.gz \
+ share/man/man7/certbot.7.gz
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
${WRKSRC}/certbot/compat/misc.py \
${WRKSRC}/tests/cli_test.py
+post-build-MANPAGES-on:
+ # Avoid gmake / ${DO_MAKE_BUILD} -C ${WRKSRC}/docs man
+ (cd ${WRKSRC}/docs && \
+ sphinx-build-${PYTHON_VER} -N -b man . _build/man)
+
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/periodic/weekly
${INSTALL_SCRIPT} ${WRKDIR}/500.certbot \
- ${STAGEDIR}${PREFIX}/etc/periodic/weekly
+ ${STAGEDIR}${PREFIX}/etc/periodic/weekly/500.certbot-${PYTHON_VER}
+
+post-install-MANPAGES-on:
+ ${INSTALL_MAN} ${WRKSRC}/docs/_build/man/certbot.1 \
+ ${STAGEDIR}${PREFIX}/share/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/docs/_build/man/certbot.7 \
+ ${STAGEDIR}${PREFIX}/share/man/man7
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test