aboutsummaryrefslogtreecommitdiff
path: root/security/py-exscript
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-09-09 14:58:48 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-09-09 14:58:48 +0000
commitc7dfb4313d3b0fb8f4502bbbbb28fd7745c79008 (patch)
treedc69ca151e38db68820dcf3086c47b6df5e390c1 /security/py-exscript
parent54934d31601a1ddacf1bc1c8a8aa262b5a3b5979 (diff)
downloadports-c7dfb4313d3b0fb8f4502bbbbb28fd7745c79008.tar.gz
ports-c7dfb4313d3b0fb8f4502bbbbb28fd7745c79008.zip
[NEW PORT]: security/py-exscript
Exscript is a Python module and a template processor for automating network connections over protocols such as Telnet or SSH. We attempt to create the best possible set of tools for working with Telnet and SSH. WWW: https://github.com/knipknap/exscript PR: 233999 Submitted by: rozhuk.im@gmail.com (initial version), jhay Reviewed by: koobs
Notes
Notes: svn path=/head/; revision=511633
Diffstat (limited to 'security/py-exscript')
-rw-r--r--security/py-exscript/Makefile36
-rw-r--r--security/py-exscript/distinfo3
-rw-r--r--security/py-exscript/pkg-descr6
3 files changed, 45 insertions, 0 deletions
diff --git a/security/py-exscript/Makefile b/security/py-exscript/Makefile
new file mode 100644
index 000000000000..78ac193ebd28
--- /dev/null
+++ b/security/py-exscript/Makefile
@@ -0,0 +1,36 @@
+# $FreeBSD$
+
+PORTNAME= exscript
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.6
+CATEGORIES= security python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= jhay@FreeBSD.org
+COMMENT= Automating Telnet and SSH
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}configparser>0:devel/py-configparser@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}paramiko>0:security/py-paramiko@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycryptodomex>0:security/py-pycryptodomex@${PY_FLAVOR}
+
+USES= python
+# Upstream doesn't provide a sdist, yet
+USE_GITHUB= yes
+GH_ACCOUNT= knipknap
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ "{s#__version__ = '[^']*'#__version__ = '${PORTVERSION}'#;}" \
+ ${BUILD_WRKSRC}/VERSION.in ${BUILD_WRKSRC}/Exscript/version.py
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m unittest discover -v tests/Exscript "*Test.py"
+
+.include <bsd.port.mk>
diff --git a/security/py-exscript/distinfo b/security/py-exscript/distinfo
new file mode 100644
index 000000000000..2beea4faca7f
--- /dev/null
+++ b/security/py-exscript/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565510934
+SHA256 (knipknap-exscript-v2.6_GH0.tar.gz) = e3e2064d0183d30bd9cdb13ee760603e4cd0ff190ae2ac8f97329300967dca90
+SIZE (knipknap-exscript-v2.6_GH0.tar.gz) = 272225
diff --git a/security/py-exscript/pkg-descr b/security/py-exscript/pkg-descr
new file mode 100644
index 000000000000..60217a3e72a1
--- /dev/null
+++ b/security/py-exscript/pkg-descr
@@ -0,0 +1,6 @@
+Exscript is a Python module and a template processor for automating network
+connections over protocols such as Telnet or SSH.
+We attempt to create the best possible set of tools for working with
+Telnet and SSH.
+
+WWW: https://github.com/knipknap/exscript