aboutsummaryrefslogtreecommitdiff
path: root/security/py-google-auth
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 23:49:14 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-01-30 23:51:43 +0000
commit50a36941aa4884228768c1d8d620872662f96e8f (patch)
treebf3550b6f8aa3aaa1d546fd71e926a13fbdf69a0 /security/py-google-auth
parentf36949eb733a8801b46de3f6f77995fb32de636d (diff)
downloadports-50a36941aa4884228768c1d8d620872662f96e8f.tar.gz
ports-50a36941aa4884228768c1d8d620872662f96e8f.zip
security/py-google-auth: Add REQUESTS option
Diffstat (limited to 'security/py-google-auth')
-rw-r--r--security/py-google-auth/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/security/py-google-auth/Makefile b/security/py-google-auth/Makefile
index 34e4823968a1..6333b001921d 100644
--- a/security/py-google-auth/Makefile
+++ b/security/py-google-auth/Makefile
@@ -21,13 +21,15 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-OPTIONS_DEFINE= AIOHTTP REAUTH
-OPTIONS_DEFAULT=AIOHTTP
+OPTIONS_DEFINE= AIOHTTP REAUTH REQUESTS
+OPTIONS_DEFAULT=AIOHTTP REQUESTS
AIOHTTP_DESC= Use aiohttp
REAUTH_DESC= Reauth support
+REQUESTS_DESC= Requests support
AIOHTTP_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=3.6.2<4.0.0:www/py-aiohttp@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.20.0<3.0.0:www/py-requests@${PY_FLAVOR}
REAUTH_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyu2f>=0.1.5:net/py-pyu2f@${PY_FLAVOR}
+REQUESTS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.20.0<3.0.0:www/py-requests@${PY_FLAVOR}
.include <bsd.port.mk>