aboutsummaryrefslogtreecommitdiff
path: root/security/py-maec
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2016-10-23 09:21:53 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2016-10-23 09:21:53 +0000
commit6eca441447d88a97995ca7717939ee836f10f8f8 (patch)
tree6369bbc34914f5c444079d8d5410ee6334710728 /security/py-maec
parent0f5fe930cfc2b499cf7aebf2cc83d59e109a29ad (diff)
downloadports-6eca441447d88a97995ca7717939ee836f10f8f8.tar.gz
ports-6eca441447d88a97995ca7717939ee836f10f8f8.zip
New port: security/py-maec
A Python library for parsing, manipulating, and generating MAEC content WWW: https://github.com/MAECProject/python-maec
Notes
Notes: svn path=/head/; revision=424505
Diffstat (limited to 'security/py-maec')
-rw-r--r--security/py-maec/Makefile40
-rw-r--r--security/py-maec/distinfo3
-rw-r--r--security/py-maec/pkg-descr3
3 files changed, 46 insertions, 0 deletions
diff --git a/security/py-maec/Makefile b/security/py-maec/Makefile
new file mode 100644
index 000000000000..0a399d5c71bd
--- /dev/null
+++ b/security/py-maec/Makefile
@@ -0,0 +1,40 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= maec
+PORTVERSION= 4.1.0.12
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Python library for parsing, manipulating, and generating MAEC content
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=2.2.3:devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}cybox>=2.1.0.11:security/py-cybox
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose
+
+NO_ARCH= yes
+USES= python:2.7
+USE_PYTHON= distutils autoplist
+
+PORTDOCS= README.rst
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+
+do-test:
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} nosetests-${PYTHON_VER})
+
+.include <bsd.port.mk>
diff --git a/security/py-maec/distinfo b/security/py-maec/distinfo
new file mode 100644
index 000000000000..b99f8905df91
--- /dev/null
+++ b/security/py-maec/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476607811
+SHA256 (maec-4.1.0.12.tar.gz) = be46cfd50b7b14701e90c52ceac0e62c0d3e83c3929736b51fba1c5c0bf6d1ac
+SIZE (maec-4.1.0.12.tar.gz) = 153351
diff --git a/security/py-maec/pkg-descr b/security/py-maec/pkg-descr
new file mode 100644
index 000000000000..e5ec0ee69dbd
--- /dev/null
+++ b/security/py-maec/pkg-descr
@@ -0,0 +1,3 @@
+A Python library for parsing, manipulating, and generating MAEC content
+
+WWW: https://github.com/MAECProject/python-maec