aboutsummaryrefslogtreecommitdiff
path: root/security/py-msoffcrypto-tool/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-12-12 21:01:51 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-12-12 21:01:51 +0000
commit9b2f9b201f78768d060ca97bef043d51b1baf202 (patch)
treebcbdda2763e8f23294485a00243200312e5b06cd /security/py-msoffcrypto-tool/Makefile
parent98eeedd0083c4b86e70519436ffe3133d52781dc (diff)
downloadports-9b2f9b201f78768d060ca97bef043d51b1baf202.tar.gz
ports-9b2f9b201f78768d060ca97bef043d51b1baf202.zip
New port: security/py-msoffcrypto-tool
msoffcrypto-tool (formerly ms-offcrypto-tool) is a Python tool and library for decrypting encrypted MS Office files with password, intermediate key, or private key which generated its escrow key. WWW: https://github.com/nolze/msoffcrypto-tool
Notes
Notes: svn path=/head/; revision=487325
Diffstat (limited to 'security/py-msoffcrypto-tool/Makefile')
-rw-r--r--security/py-msoffcrypto-tool/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/security/py-msoffcrypto-tool/Makefile b/security/py-msoffcrypto-tool/Makefile
new file mode 100644
index 000000000000..105dcceb8cb1
--- /dev/null
+++ b/security/py-msoffcrypto-tool/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= msoffcrypto-tool
+PORTVERSION= 4.6.3
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Python tool and library for decrypting MS Office files
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.3:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}olefile>=0.45:devel/py-olefile@${PY_FLAVOR}
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= concurrent distutils autoplist
+
+.include <bsd.port.mk>