aboutsummaryrefslogtreecommitdiff
path: root/security/py-oauthlib
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-02-26 10:53:49 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-02-26 10:53:49 +0000
commit50798bfc7e3d15acfe6dd4580e3c4f415151ac8d (patch)
tree7b215813a49a59bc9916ff7314ba16ee17411fdc /security/py-oauthlib
parent4c8eccf2bd0cb767d17c1e61c2dc2a512a8d5b02 (diff)
downloadports-50798bfc7e3d15acfe6dd4580e3c4f415151ac8d.tar.gz
ports-50798bfc7e3d15acfe6dd4580e3c4f415151ac8d.zip
security/py-oauthlib: Update 1.0.3
- Update PORTVERSION and distinfo checksum (1.0.3) - Update COMMENT to more closely match setup.py:description= - Update TEST dependencies and test target - Remove TESTS option bits accordingly - Move mock to only Python 2.x TEST_DEPENDS - Enable NO_ARCH (architecture independent) - Add LICENSE_FILE
Notes
Notes: svn path=/head/; revision=409596
Diffstat (limited to 'security/py-oauthlib')
-rw-r--r--security/py-oauthlib/Makefile42
-rw-r--r--security/py-oauthlib/distinfo4
2 files changed, 22 insertions, 24 deletions
diff --git a/security/py-oauthlib/Makefile b/security/py-oauthlib/Makefile
index 5b6d0e4934e6..51599acbb5db 100644
--- a/security/py-oauthlib/Makefile
+++ b/security/py-oauthlib/Makefile
@@ -2,52 +2,50 @@
# $FreeBSD$
PORTNAME= oauthlib
-PORTVERSION= 0.7.2
-PORTREVISION= 1
+PORTVERSION= 1.0.3
CATEGORIES= security net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
-COMMENT= RFC-compliant Python implementation of OAuth
+COMMENT= RFC-compliant implementation of the OAuth request-signing logic
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
-TEST_DEPENDS= nosetests:${PORTSDIR}/devel/py-nose \
- ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}pyjwt>0:${PORTSDIR}/www/py-pyjwt \
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>0:${PORTSDIR}/security/py-cryptography \
+ ${PYTHON_PKGNAMEPREFIX}pyjwt>=1.0.0:${PORTSDIR}/www/py-pyjwt \
${PYTHON_PKGNAMEPREFIX}blinker>0:${PORTSDIR}/devel/py-blinker
-OPTIONS_DEFINE= RSA SIGNALS SIGNEDTOKEN TESTS
+OPTIONS_DEFINE= RSA SIGNALS SIGNEDTOKEN
OPTIONS_DEFAULT= RSA SIGNALS SIGNEDTOKEN
-RSA_DESC= Enable RSA Support
-RSA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypto
+RSA_DESC= Enable RSA Support
+SIGNALS_DESC= Enable signal support
+SIGNEDTOKEN_DESC= Support for Signed Token
-SIGNALS_DESC= Enable signal support
+RSA_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:${PORTSDIR}/security/py-cryptography
SIGNALS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}blinker>0:${PORTSDIR}/devel/py-blinker
-
-SIGNEDTOKEN_DESC= Support for Signed Token
-SIGNEDTOKEN_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}pyjwt>0:${PORTSDIR}/www/py-pyjwt
-
-TESTS_DESC= Include test suite dependencies
-TESTS_BUILD_DEPENDS= ${TEST_DEPENDS}
+SIGNEDTOKEN_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:${PORTSDIR}/security/py-cryptography \
+ ${PYTHON_PKGNAMEPREFIX}pyjwt>=1.0.0:${PORTSDIR}/www/py-pyjwt
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3000
-TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2
+TEST_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2 \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
.endif
post-extract:
@${CHMOD} -R a+rX ${WRKSRC}
-regression-test: build
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.post.mk>
diff --git a/security/py-oauthlib/distinfo b/security/py-oauthlib/distinfo
index 55f5c6d16b2f..e42c0f9f4585 100644
--- a/security/py-oauthlib/distinfo
+++ b/security/py-oauthlib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (oauthlib-0.7.2.tar.gz) = a051f04ee8ec3305055ab34d87b36c9a449375e07c7d6a05bcafa48329cac7c3
-SIZE (oauthlib-0.7.2.tar.gz) = 106079
+SHA256 (oauthlib-1.0.3.tar.gz) = ef4bfe4663ca3b97a995860c0173b967ebd98033d02f38c9e1b2cbb6c191d9ad
+SIZE (oauthlib-1.0.3.tar.gz) = 109095