aboutsummaryrefslogtreecommitdiff
path: root/security/py-pgpy
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-04-25 15:39:57 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-04-25 15:39:57 +0000
commit80e49d7873fe5ff1817e55a7f541d60b9bb4b153 (patch)
tree5c81c0950adab4b269e4bdf0ff2eda6dd4fea4ac /security/py-pgpy
parent862110f54bf0398b4e8dc4c5be62131f5a44300b (diff)
downloadports-80e49d7873fe5ff1817e55a7f541d60b9bb4b153.tar.gz
ports-80e49d7873fe5ff1817e55a7f541d60b9bb4b153.zip
Add security/py-pgpy: Pretty Good Privacy for Python
PGPy is a Python (2 and 3) library for implementing Pretty Good Privacy into Python programs, conforming to the OpenPGP specification per RFC 4880. WWW: https://github.com/SecurityInnovation/PGPy PR: 245335 Submitted by: contact@evilham.com
Notes
Notes: svn path=/head/; revision=532957
Diffstat (limited to 'security/py-pgpy')
-rw-r--r--security/py-pgpy/Makefile25
-rw-r--r--security/py-pgpy/distinfo3
-rw-r--r--security/py-pgpy/pkg-descr4
3 files changed, 32 insertions, 0 deletions
diff --git a/security/py-pgpy/Makefile b/security/py-pgpy/Makefile
new file mode 100644
index 000000000000..a34653cf230d
--- /dev/null
+++ b/security/py-pgpy/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= pgpy
+PORTVERSION= 0.5.2
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PGPy-${PORTVERSION}
+
+MAINTAINER= contact@evilham.com
+COMMENT= Pretty Good Privacy for Python
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.6:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyasn1>=0:devel/py-pyasn1@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-pgpy/distinfo b/security/py-pgpy/distinfo
new file mode 100644
index 000000000000..a236e71b40d8
--- /dev/null
+++ b/security/py-pgpy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1585942192
+SHA256 (PGPy-0.5.2.tar.gz) = a702668a8b8fb84889ecd840da63c9e323d19bc2132cc5478d534ede3ec49444
+SIZE (PGPy-0.5.2.tar.gz) = 73523
diff --git a/security/py-pgpy/pkg-descr b/security/py-pgpy/pkg-descr
new file mode 100644
index 000000000000..dd47d0b0d3d7
--- /dev/null
+++ b/security/py-pgpy/pkg-descr
@@ -0,0 +1,4 @@
+PGPy is a Python (2 and 3) library for implementing Pretty Good Privacy into
+Python programs, conforming to the OpenPGP specification per RFC 4880.
+
+WWW: https://github.com/SecurityInnovation/PGPy