aboutsummaryrefslogtreecommitdiff
path: root/security/py-plaso/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /security/py-plaso/Makefile
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'security/py-plaso/Makefile')
-rw-r--r--security/py-plaso/Makefile45
1 files changed, 22 insertions, 23 deletions
diff --git a/security/py-plaso/Makefile b/security/py-plaso/Makefile
index 4ac046af70e0..14c8bbb25afd 100644
--- a/security/py-plaso/Makefile
+++ b/security/py-plaso/Makefile
@@ -27,28 +27,27 @@ RUN_DEPENDS= hachoir-core>=0:devel/hachoir-core \
libolecf>=a:devel/libolecf \
libregf>=a:devel/libregf \
libscca>=a:devel/libscca \
- ${PYTHON_PKGNAMEPREFIX}artifacts>=0:security/py-artifacts \
- ${PYTHON_PKGNAMEPREFIX}bencode.py>=0:converters/py-bencode.py \
- ${PYTHON_PKGNAMEPREFIX}binplist>=0:devel/py-binplist \
- ${PYTHON_PKGNAMEPREFIX}construct>=0:devel/py-construct \
- ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil \
- ${PYTHON_PKGNAMEPREFIX}dfdatetime>=0:security/py-dfdatetime \
- ${PYTHON_PKGNAMEPREFIX}dfvfs>=0:security/py-dfvfs \
- ${PYTHON_PKGNAMEPREFIX}dfwinreg>=0:security/py-dfwinreg \
- ${PYTHON_PKGNAMEPREFIX}dpkt>=0:net/py-dpkt \
- ${PYTHON_PKGNAMEPREFIX}efilter>=0:devel/py-efilter \
- ${PYTHON_PKGNAMEPREFIX}pefile>=0:devel/py-pefile \
- ${PYTHON_PKGNAMEPREFIX}psutil>=0:sysutils/py-psutil \
- ${PYTHON_PKGNAMEPREFIX}pyparsing>=0:devel/py-pyparsing \
- ${PYTHON_PKGNAMEPREFIX}pytsk>=0:sysutils/py-pytsk \
- ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz \
- ${PYTHON_PKGNAMEPREFIX}pyzmq>=0:net/py-pyzmq \
- ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}XlsxWriter>=0:textproc/py-xlsxwriter \
- ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml \
- ${PYTHON_PKGNAMEPREFIX}yara>=0:security/py-yara
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock
+ ${PYTHON_PKGNAMEPREFIX}artifacts>=0:security/py-artifacts@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}bencode.py>=0:converters/py-bencode.py@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}binplist>=0:devel/py-binplist@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}construct>=0:devel/py-construct@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dfvfs>=0:security/py-dfvfs@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dfwinreg>=0:security/py-dfwinreg@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dpkt>=0:net/py-dpkt@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}efilter>=0:devel/py-efilter@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pefile>=0:devel/py-pefile@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>=0:sysutils/py-psutil@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyparsing>=0:devel/py-pyparsing@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytsk>=0:sysutils/py-pytsk@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyzmq>=0:net/py-pyzmq@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}XlsxWriter>=0:textproc/py-xlsxwriter@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yara>=0:security/py-yara@${FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${FLAVOR}
NO_ARCH= yes
USES= python:2.7
@@ -59,7 +58,7 @@ TEST_ENV= ${MAKE_ENV} PYTHONHTTPSVERIFY=0
.include <bsd.port.pre.mk>
.if ${PYTHON_REL} < 3300
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pyliblzma>=0:archivers/py-pyliblzma
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pyliblzma>=0:archivers/py-pyliblzma@${FLAVOR}
.endif
do-test: