aboutsummaryrefslogtreecommitdiff
path: root/security/py-pwntools
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-23 15:47:22 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-23 15:47:22 +0000
commitbc050a1dd6752abe07621561d6942280760becc1 (patch)
tree4d3360c033b871697a435a9c5132e5e5a1d65134 /security/py-pwntools
parent89d5c3e7c19ceee11f7f1b9db62b45c28e888dba (diff)
downloadports-bc050a1dd6752abe07621561d6942280760becc1.tar.gz
ports-bc050a1dd6752abe07621561d6942280760becc1.zip
security/py-pwntools: Add new port
Pwntools is a CTF framework and exploit development library. Written in Python, it is designed for rapid prototyping and development, and intended to make exploit writing as simple as possible. WWW: https://github.com/Gallopsled/pwntools
Diffstat (limited to 'security/py-pwntools')
-rw-r--r--security/py-pwntools/Makefile40
-rw-r--r--security/py-pwntools/distinfo3
-rw-r--r--security/py-pwntools/pkg-descr5
3 files changed, 48 insertions, 0 deletions
diff --git a/security/py-pwntools/Makefile b/security/py-pwntools/Makefile
new file mode 100644
index 000000000000..93041c9de483
--- /dev/null
+++ b/security/py-pwntools/Makefile
@@ -0,0 +1,40 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+
+PORTNAME= pwntools
+PORTVERSION= 4.7.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= CTF framework and exploit development library
+
+LICENSE= BSD2CLAUSE GPLv2 MIT
+LICENSE_COMB= multi
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}capstone>=3.0.5rc2:devel/py-capstone@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}colored-traceback>0:devel/py-colored-traceback@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}intervaltree>=3.0:devel/py-intervaltree@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mako>=1.0.0:textproc/py-mako@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}paramiko>=1.15.2:security/py-paramiko@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pip>=6.0.8:devel/py-pip@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}psutil>=3.3.0:sysutils/py-psutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyelftools>=0.2.4:devel/py-pyelftools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=2.9:textproc/py-pygments@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyserial>=2.7:comms/py-pyserial@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pysocks>0:net/py-pysocks@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ropgadget>0:security/py-ropgadget@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}rpyc>0:devel/py-RPyC@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.12.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sortedcontainers>0:devel/py-sortedcontainers@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}unicorn>=1.0.2rc1:emulators/py-unicorn@${PY_FLAVOR}
+
+#RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}capstone>=3.0.5:devel/py-capstone@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}dateutil>0:devel/py-dateutil@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}intervaltree>=3.0:devel/py-intervaltree@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}mako>=1.0.0:textproc/py-mako@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}packaging>=0:devel/py-packaging@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}paramiko>=1.15.2:security/py-paramiko@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}pip>=6.0.8:devel/py-pip@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}psutil>=3.3.0:sysutils/py-psutil@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}pyelftools>=0.2.4:devel/py-pyelftools@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}pygments>=2.9:textproc/py-pygments@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}pyserial>=2.7:comms/py-pyserial@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}pysocks>0:net/py-pysocks@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}requests>=2.0:www/py-requests@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}rpyc>0:devel/py-RPyC@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}six>=1.12.0:devel/py-six@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}sortedcontainers>0:devel/py-sortedcontainers@${PY_FLAVOR} # ${PYTHON_PKGNAMEPREFIX}unicorn>=1.0.2:emulators/py-unicorn@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-pwntools/distinfo b/security/py-pwntools/distinfo
new file mode 100644
index 000000000000..f71d0004882e
--- /dev/null
+++ b/security/py-pwntools/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1649753693
+SHA256 (pwntools-4.7.0.tar.gz) = 74388e28675e7a1929f763df5a1cec6a3d589641049b6cf476bb1c56ec50a88e
+SIZE (pwntools-4.7.0.tar.gz) = 5263930
diff --git a/security/py-pwntools/pkg-descr b/security/py-pwntools/pkg-descr
new file mode 100644
index 000000000000..e0e472e8be8c
--- /dev/null
+++ b/security/py-pwntools/pkg-descr
@@ -0,0 +1,5 @@
+Pwntools is a CTF framework and exploit development library. Written in
+Python, it is designed for rapid prototyping and development, and
+intended to make exploit writing as simple as possible.
+
+WWW: https://github.com/Gallopsled/pwntools