aboutsummaryrefslogtreecommitdiff
path: root/security/py-pyclamd
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-06-11 02:50:03 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-06-11 02:50:03 +0000
commite54cd09207e2a8f6516c6a7c78999fe91c85ea61 (patch)
tree52afec4941ffb31ab365493635cf4f17e61b31b8 /security/py-pyclamd
parente4ce71c1e2337b42a9b173f9eaf305ab51187bbd (diff)
downloadports-e54cd09207e2a8f6516c6a7c78999fe91c85ea61.tar.gz
ports-e54cd09207e2a8f6516c6a7c78999fe91c85ea61.zip
- Update to 0.2.2.
PR: ports/157744 Submitted by: Milan Obuch <bsd@dino.sk> (maintainer)
Notes
Notes: svn path=/head/; revision=275336
Diffstat (limited to 'security/py-pyclamd')
-rw-r--r--security/py-pyclamd/Makefile2
-rw-r--r--security/py-pyclamd/distinfo5
-rw-r--r--security/py-pyclamd/files/patch-pyclamd.py52
-rw-r--r--security/py-pyclamd/files/patch-setup.py2
4 files changed, 30 insertions, 31 deletions
diff --git a/security/py-pyclamd/Makefile b/security/py-pyclamd/Makefile
index 9c32f6ccd16f..bc03fc411540 100644
--- a/security/py-pyclamd/Makefile
+++ b/security/py-pyclamd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pyclamd
-PORTVERSION= 0.1.1
+PORTVERSION= 0.2.2
CATEGORIES= security python
MASTER_SITES= http://xael.org/norman/python/pyclamd/
DISTFILES= pyclamd.py
diff --git a/security/py-pyclamd/distinfo b/security/py-pyclamd/distinfo
index 00eb05a9439e..d68589defde3 100644
--- a/security/py-pyclamd/distinfo
+++ b/security/py-pyclamd/distinfo
@@ -1,3 +1,2 @@
-MD5 (pyclamd.py) = fcdc195401e8c78a0d19ee6b8c23fdcb
-SHA256 (pyclamd.py) = 3542cc2271c8365a4205c563705a9f3090dca3f6242524119cb6560b7bbfcbaf
-SIZE (pyclamd.py) = 10498
+SHA256 (pyclamd.py) = 209673f947ce16d53bab43c19bfb8200f8b40cc70b26d4dbc9a0e203c561d16e
+SIZE (pyclamd.py) = 13101
diff --git a/security/py-pyclamd/files/patch-pyclamd.py b/security/py-pyclamd/files/patch-pyclamd.py
index 029b4ee6c049..a80e2f2df701 100644
--- a/security/py-pyclamd/files/patch-pyclamd.py
+++ b/security/py-pyclamd/files/patch-pyclamd.py
@@ -1,38 +1,38 @@
---- pyclamd.py.orig 2007-04-11 18:10:26.000000000 +0200
-+++ pyclamd.py 2007-08-28 11:28:48.000000000 +0200
-@@ -14,7 +14,7 @@
- # Network
- pyclamd.init_network_socket('localhost', 3310)
- # Unix local socket
-- #pyclamd.init_unix_socket('/var/run/clamd')
-+ #pyclamd.init_unix_socket('/var/run/clamav/clamd')
+--- pyclamd.py.orig 2011-01-26 20:08:38.000000000 +0100
++++ pyclamd.py 2011-01-26 20:14:58.000000000 +0100
+@@ -51,7 +51,7 @@
+ # Network
+ pyclamd.init_network_socket('localhost', 3310)
+ # Unix local socket
+- #pyclamd.init_unix_socket('/var/run/clamd')
++ #pyclamd.init_unix_socket('/var/run/clamav/clamd.sock')
- # Get Clamscan version
- print pyclamd.version()
-@@ -29,7 +29,7 @@
+ # Get Clamscan version
+ print pyclamd.version()
+@@ -66,7 +66,7 @@
Test strings :
^^^^^^^^^^^^
>>> try:
--... init_unix_socket('/var/run/clamd')
-+... init_unix_socket('/var/run/clamav/clamd')
+-... init_unix_socket('/var/run/clamav/clamd.ctl')
++... init_unix_socket('/var/run/clamav/clamd.sock')
... except ScanError:
- ... init_network_socket('localhost', 3310)
+ ... init_network_socket('localhost', 3310)
...
-@@ -68,7 +68,7 @@
+@@ -110,7 +110,7 @@
# Default values for globals
use_socket = None
--clamd_SOCKET = "/var/run/clamd"
-+clamd_SOCKET = "/var/run/clamav/clamd"
- clamd_HOST='127.0.0.1'
- clamd_PORT=3310
+-clamd_SOCKET = "/var/run/clamav/clamd.ctl"
++clamd_SOCKET = "/var/run/clamav/clamd.sock"
+ clamd_HOST = '127.0.0.1'
+ clamd_PORT = 3310
+ clamd_timeout = None #[PL] default timeout for sockets: None = blocking operations
+@@ -121,7 +121,7 @@
-@@ -85,7 +85,7 @@
-
############################################################################
--def init_unix_socket(filename="/var/run/clamd"):
-+def init_unix_socket(filename="/var/run/clamav/clamd"):
- """
- Init pyclamd to use clamd unix local socket
-
+-def init_unix_socket(filename="/var/run/clamav/clamd.ctl"):
++def init_unix_socket(filename="/var/run/clamav/clamd.sock"):
+ """
+ Init pyclamd to use clamd unix local socket
+
diff --git a/security/py-pyclamd/files/patch-setup.py b/security/py-pyclamd/files/patch-setup.py
index 1d1dea40572d..29b7fcfcb8b3 100644
--- a/security/py-pyclamd/files/patch-setup.py
+++ b/security/py-pyclamd/files/patch-setup.py
@@ -9,7 +9,7 @@
+from distutils.core import setup
+
+setup(name="pyclamd",
-+ version="0.1.1",
++ version="0.2.2",
+ description="Python ClamD module.",
+ author="Alexandre Norman",
+ author_email="norman@xael.org",