aboutsummaryrefslogtreecommitdiff
path: root/security/py-pysha3/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-07-30 14:16:38 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-07-30 14:16:38 +0000
commit486caf99151c2047d2c36740ef9807d4daf8a24f (patch)
tree81f4b48e1b84f20aee9deb08cd1bf389ac44eb4b /security/py-pysha3/Makefile
parent9bbe93456a4394c58afa6bcd8f686de24da6f8ab (diff)
downloadports-486caf99151c2047d2c36740ef9807d4daf8a24f.tar.gz
ports-486caf99151c2047d2c36740ef9807d4daf8a24f.zip
security/py-pysha3: Update to 1.0b1, Modernize
* Update DISTVERSION and distinfo (1.0b1) * Add LICENSE_FILE * Sort USE_PYTHON * Update test target * Strip shared library * Remove vestigial files/py3k-fix-pkg-plist.in patch
Notes
Notes: svn path=/head/; revision=419319
Diffstat (limited to 'security/py-pysha3/Makefile')
-rw-r--r--security/py-pysha3/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/security/py-pysha3/Makefile b/security/py-pysha3/Makefile
index 79a389134796..b1498effc591 100644
--- a/security/py-pysha3/Makefile
+++ b/security/py-pysha3/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pysha3
-PORTVERSION= 0.3
-PORTREVISION= 1
+DISTVERSION= 1.0b1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,11 +11,16 @@ MAINTAINER= koobs@FreeBSD.org
COMMENT= SHA-3 (Keccak) for Python
LICENSE= PSFL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+# Actually Python 2.7,3.4+
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist distutils
-regression-test: build
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_sha3.so
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>