aboutsummaryrefslogtreecommitdiff
path: root/security/py-pysha3/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-10-17 08:03:42 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-10-17 08:03:42 +0000
commit8d11ec6917587dd8ffc26585b42d94fb2c5fcb64 (patch)
tree99cb895814bc4323dcb0540e5a2f6563708f8cc8 /security/py-pysha3/Makefile
parente33759adb407d90b1d0fbf217c30c9dba727e40b (diff)
downloadports-8d11ec6917587dd8ffc26585b42d94fb2c5fcb64.tar.gz
ports-8d11ec6917587dd8ffc26585b42d94fb2c5fcb64.zip
sha3 wrapper (keccak) for Python. The package is a wrapper around the
optimized reference implementation from http://keccak.noekeon.org/ . Only the optimizations for 32 and 64bit platforms are used. The optimized SSE and ARM assembly variants are ignored for now. The module is a standalone version of the SHA-3 implemention of Python 3.4 (currently under development). WWW: http://bitbucket.org/tiran/pykeccak PR: 172606 Submitted by: Kubilay Kocak <koobs.freebsd at gmail dot com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=306002
Diffstat (limited to 'security/py-pysha3/Makefile')
-rw-r--r--security/py-pysha3/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/security/py-pysha3/Makefile b/security/py-pysha3/Makefile
new file mode 100644
index 000000000000..f716b0f1268e
--- /dev/null
+++ b/security/py-pysha3/Makefile
@@ -0,0 +1,31 @@
+# Created by: Kubilay Kocak <koobs.freebsd@gmail.com>
+# $FreeBSD$
+
+PORTNAME= pysha3
+PORTVERSION= 0.2.2
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs.freebsd@gmail.com
+COMMENT= SHA-3 (Keccak) for Python
+
+# Python3 ready
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/_sha3.so \
+ %%PYTHON_SITELIBDIR%%/sha3.py \
+ %%PYTHON_SITELIBDIR%%/sha3.pyc \
+ %%PYTHON_SITELIBDIR%%/sha3.pyo
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 320
+.include "${FILESDIR}/py3k-fix-pkg-plist.inc"
+.endif
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+
+.include <bsd.port.post.mk>