aboutsummaryrefslogtreecommitdiff
path: root/security/py-pyspnego
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-08 17:10:51 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-11-08 17:10:51 +0000
commit8556cade2b3f0d53e65da5217f128832ac10df53 (patch)
treecc6324d46d297c84997da9a8eec97a0825aedb7b /security/py-pyspnego
parent3d2c1e8a6085a377a6894ccb5b3bf24e9e61ad05 (diff)
downloadports-8556cade2b3f0d53e65da5217f128832ac10df53.tar.gz
ports-8556cade2b3f0d53e65da5217f128832ac10df53.zip
Add py-pyspnego 0.1.3
Library to handle SPNEGO (Negotiate, NTLM, Kerberos) authentication. Also includes a packet parser that can be used to decode raw NTLM/SPNEGO/Kerberos tokens into a human readable format. WWW: https://github.com/jborean93/pyspnego
Notes
Notes: svn path=/head/; revision=554480
Diffstat (limited to 'security/py-pyspnego')
-rw-r--r--security/py-pyspnego/Makefile29
-rw-r--r--security/py-pyspnego/distinfo3
-rw-r--r--security/py-pyspnego/pkg-descr5
3 files changed, 37 insertions, 0 deletions
diff --git a/security/py-pyspnego/Makefile b/security/py-pyspnego/Makefile
new file mode 100644
index 000000000000..54e1557a1b12
--- /dev/null
+++ b/security/py-pyspnego/Makefile
@@ -0,0 +1,29 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pyspnego
+PORTVERSION= 0.1.3
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Windows Negotiate Authentication Client and Server
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= YAML
+YAML_DESC= YAML output support
+
+YAML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ruamel.yaml>=0:devel/py-ruamel.yaml@${PY_FLAVOR}
+
+.include <bsd.port.mk>
+
diff --git a/security/py-pyspnego/distinfo b/security/py-pyspnego/distinfo
new file mode 100644
index 000000000000..ca2fc09fdc2b
--- /dev/null
+++ b/security/py-pyspnego/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1604680060
+SHA256 (pyspnego-0.1.3.tar.gz) = a2963d52b64ecd7df3f8e9a311a423e75bd4bcc5944d46da16837607f9f6e667
+SIZE (pyspnego-0.1.3.tar.gz) = 94432
diff --git a/security/py-pyspnego/pkg-descr b/security/py-pyspnego/pkg-descr
new file mode 100644
index 000000000000..1e9966f5fd4d
--- /dev/null
+++ b/security/py-pyspnego/pkg-descr
@@ -0,0 +1,5 @@
+Library to handle SPNEGO (Negotiate, NTLM, Kerberos) authentication. Also
+includes a packet parser that can be used to decode raw NTLM/SPNEGO/Kerberos
+tokens into a human readable format.
+
+WWW: https://github.com/jborean93/pyspnego