aboutsummaryrefslogtreecommitdiff
path: root/security/py-rekall-core
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2016-04-16 13:31:18 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2016-04-16 13:31:18 +0000
commit4a20178fa46fa6375e3383d9f8565636c0e2eff2 (patch)
treec66acf28f2c941192ce8103156ca1a3ee38c65eb /security/py-rekall-core
parentbd686466822df5b2eca4b55c2451a74cf57f38a2 (diff)
downloadports-4a20178fa46fa6375e3383d9f8565636c0e2eff2.tar.gz
ports-4a20178fa46fa6375e3383d9f8565636c0e2eff2.zip
Update rekall to 1.5.0
Notes
Notes: svn path=/head/; revision=413440
Diffstat (limited to 'security/py-rekall-core')
-rw-r--r--security/py-rekall-core/Makefile33
-rw-r--r--security/py-rekall-core/distinfo4
-rw-r--r--security/py-rekall-core/files/patch-setup.py39
3 files changed, 59 insertions, 17 deletions
diff --git a/security/py-rekall-core/Makefile b/security/py-rekall-core/Makefile
index 9bf633a43fe4..16537343fa70 100644
--- a/security/py-rekall-core/Makefile
+++ b/security/py-rekall-core/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rekall-core
-PORTVERSION= 1.4.1
+DISTVERSION= 1.5.0.post5
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,22 +13,25 @@ COMMENT= CORE component of the Rekall framework
LICENSE= GPLv2
RUN_DEPENDS= cabextract:archivers/cabextract \
- ${PYTHON_PKGNAMEPREFIX}acora>=1.8:textproc/py-acora \
- ${PYTHON_PKGNAMEPREFIX}PyAFF4>=0.17:security/py-pyaff4 \
- ${PYTHON_PKGNAMEPREFIX}capstone>=0:devel/py-capstone \
- ${PYTHON_PKGNAMEPREFIX}distorm>=0:devel/py-distorm \
- ${PYTHON_PKGNAMEPREFIX}efilter>=1438631774:devel/py-efilter \
- ${PYTHON_PKGNAMEPREFIX}intervaltree>=2.0.4:devel/py-intervaltree \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.3.1:security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}pyelftools>=0.22:devel/py-pyelftools \
- ${PYTHON_PKGNAMEPREFIX}pytz>=2012:devel/py-pytz \
- ${PYTHON_PKGNAMEPREFIX}yaml>=2.10:devel/py-yaml \
- ${PYTHON_PKGNAMEPREFIX}yara>=0:security/py-yara
+ ${PYTHON_PKGNAMEPREFIX}PyAFF4>=0.23:security/py-pyaff4 \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}acora>=1.9:textproc/py-acora \
+ ${PYTHON_PKGNAMEPREFIX}arrow>=0.7.0:devel/py-arrow \
+ ${PYTHON_PKGNAMEPREFIX}efilter>=1453815385:devel/py-efilter \
+ ${PYTHON_PKGNAMEPREFIX}intervaltree>=2.1.0:devel/py-intervaltree \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.6.1:security/py-pycrypto \
+ ${PYTHON_PKGNAMEPREFIX}pyelftools>=0.23:devel/py-pyelftools \
+ ${PYTHON_PKGNAMEPREFIX}pytz>=2015.7:devel/py-pytz \
+ ${PYTHON_PKGNAMEPREFIX}capstone>=3.0.4:devel/py-capstone \
+ ${PYTHON_PKGNAMEPREFIX}yara>=3.4.0:security/py-yara \
+ ${PYTHON_PKGNAMEPREFIX}sortedcontainers>=1.4.4:devel/py-sortedcontainers \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=2.4.2:devel/py-dateutil
-USES= python:2
+NO_ARCH= yes
+USES= python:2.7 zip
USE_PYTHON= distutils autoplist
-post-patch:
- @${REINPLACE_CMD} '/argparse/d' ${WRKSRC}/setup.py
+post-extract:
+ @${CHMOD} -R a+rX ${WRKSRC}
.include <bsd.port.mk>
diff --git a/security/py-rekall-core/distinfo b/security/py-rekall-core/distinfo
index a7dc97aafe24..8bc1fc3cdfc2 100644
--- a/security/py-rekall-core/distinfo
+++ b/security/py-rekall-core/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rekall-core-1.4.1.tar.gz) = 2708479ab985577ce23fabf1cc7f634cf64051e9c9b2abce47e40839ef31637f
-SIZE (rekall-core-1.4.1.tar.gz) = 723180
+SHA256 (rekall-core-1.5.0.post5.zip) = 9de7174702eaab563778c63eed189b5d09a3e7294e34c3df6eca5fd0424d78fc
+SIZE (rekall-core-1.5.0.post5.zip) = 1004205
diff --git a/security/py-rekall-core/files/patch-setup.py b/security/py-rekall-core/files/patch-setup.py
new file mode 100644
index 000000000000..f966e808b1a6
--- /dev/null
+++ b/security/py-rekall-core/files/patch-setup.py
@@ -0,0 +1,39 @@
+--- setup.py.orig 2016-03-28 15:25:48 UTC
++++ setup.py
+@@ -46,23 +46,22 @@ def find_data_files(source):
+ # approach ensures that any Rekall version will always work as tested - even
+ # when external packages are upgraded in an incompatible way.
+ install_requires = [
+- "PyAFF4 >= 0.23, < 0.30",
+- "PyYAML == 3.11",
+- "acora == 1.9",
+- "argparse == 1.2.1",
+- "arrow == 0.7.0",
+- "efilter == 1453815385",
+- "intervaltree == 2.1.0",
+- "pycrypto == 2.6.1",
+- "pyelftools == 0.23",
+- "pytz == 2015.7",
+- "rekall-capstone == 3.0.4.post2",
+- "rekall-yara == 3.4.0.1",
+- "sortedcontainers == 1.4.4",
++ "PyAFF4 >= 0.23",
++ "PyYAML >= 3.11",
++ "acora >= 1.9",
++ "arrow >= 0.7.0",
++ "efilter >= 1453815385",
++ "intervaltree >= 2.1.0",
++ "pycrypto >= 2.6.1",
++ "pyelftools >= 0.23",
++ "pytz >= 2015.7",
++ "capstone >= 3.0.4",
++ "yara-python >= 3.4.0",
++ "sortedcontainers >= 1.4.4",
+
+ # Version 2.5.0 is broken with pyinstaller.
+ # https://github.com/pyinstaller/pyinstaller/issues/1848
+- "python-dateutil == 2.4.2",
++ "python-dateutil >= 2.4.2",
+ ]
+
+