aboutsummaryrefslogtreecommitdiff
path: root/security/py-rekall
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-01-07 16:42:10 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-01-07 16:42:10 +0000
commit06fcb32ef42ad643da1d28d7eeafead0148deffc (patch)
treef01fcc6f538573e6fb08700e9ac78f56565d2eda /security/py-rekall
parent51aab0b78122c5654265260392f3543ea8038def (diff)
downloadports-06fcb32ef42ad643da1d28d7eeafead0148deffc.tar.gz
ports-06fcb32ef42ad643da1d28d7eeafead0148deffc.zip
- Update py-rekall-core to 1.6.0
- Ignore py-rekall_gui: doesn't work with py-rekall-core 1.6.0 yet - Ignore py-rekall: requires ipython 5.0.0
Notes
Notes: svn path=/head/; revision=430814
Diffstat (limited to 'security/py-rekall')
-rw-r--r--security/py-rekall/Makefile12
-rw-r--r--security/py-rekall/distinfo6
-rw-r--r--security/py-rekall/files/patch-setup.py12
3 files changed, 22 insertions, 8 deletions
diff --git a/security/py-rekall/Makefile b/security/py-rekall/Makefile
index d3ddaf4fa3a7..862ef84edbbb 100644
--- a/security/py-rekall/Makefile
+++ b/security/py-rekall/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rekall
-PORTVERSION= 1.5.2
+PORTVERSION= 1.6.0
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,15 +12,17 @@ COMMENT= Memory forensics analysis framework
LICENSE= GPLv2
+IGNORE= requires ipython 5.0.0 or higher
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}rekall-core>=1.5.0.p:security/py-rekall-core \
- ${PYTHON_PKGNAMEPREFIX}rekall_gui>=1.5.0.p:security/py-rekall_gui \
${PYTHON_PKGNAMEPREFIX}ipython>=0:devel/ipython
NO_ARCH= yes
USES= python:2.7 zip
USE_PYTHON= distutils autoplist
-post-patch:
- @${REINPLACE_CMD} 's|ipython >= 4.1.2, < 5.0|ipython|' ${WRKSRC}/setup.py
+.include <bsd.port.pre.mk>
+
+PYDISTUTILS_INSTALLARGS+=--install-data ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/py-rekall/distinfo b/security/py-rekall/distinfo
index 9dbecea18b1c..55057316113a 100644
--- a/security/py-rekall/distinfo
+++ b/security/py-rekall/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1468660883
-SHA256 (rekall-1.5.2.zip) = ba6aab29e2002607369cf159d924d1f4bca341a183f73b6005f2f8c1bb36e8f8
-SIZE (rekall-1.5.2.zip) = 392183
+TIMESTAMP = 1478337079
+SHA256 (rekall-1.6.0.zip) = 261cbc31c4f1eb91b8e2cefb7a5bbfe547539b091d58ff7d91f181494ae0af8a
+SIZE (rekall-1.6.0.zip) = 301230
diff --git a/security/py-rekall/files/patch-setup.py b/security/py-rekall/files/patch-setup.py
new file mode 100644
index 000000000000..9c3d690e58e5
--- /dev/null
+++ b/security/py-rekall/files/patch-setup.py
@@ -0,0 +1,12 @@
+--- setup.py.orig 2016-11-03 22:17:38 UTC
++++ setup.py
+@@ -80,7 +80,8 @@ def find_data_files(source):
+ result = []
+ for directory, _, files in os.walk(source):
+ files = [os.path.join(directory, x) for x in files]
+- result.append((directory, files))
++ if files:
++ result.append((directory, files))
+
+ return result
+