aboutsummaryrefslogtreecommitdiff
path: root/security/py-rsa/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2013-09-26 14:40:36 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2013-09-26 14:40:36 +0000
commitbc869da5ee19dcd16773699272e4660aced89fff (patch)
tree4351da57b4ba51c9822229c433f5a0e28068e8d9 /security/py-rsa/Makefile
parent085c1a3bcbfc1a6099ba50f04af34d71a896aa87 (diff)
downloadports-bc869da5ee19dcd16773699272e4660aced89fff.tar.gz
ports-bc869da5ee19dcd16773699272e4660aced89fff.zip
security/py-rsa: Update to 3.1.2
- Update to 3.1.2 - Update pkg-plist - pkg-descr: Tab->space for WWW: - Update setup.py patch - Add TEST_DEPENDS and regression-test: target - BUILD_DEPENDS are actually RUN_DEPENDS - Whitespace alignment Changes: https://bitbucket.org/sybren/python-rsa/commits/tag/version-3.1.2 PR: ports/182298 Submitted by: Alexey Degtyarev <alexey@renatasystems.org>
Notes
Notes: svn path=/head/; revision=328367
Diffstat (limited to 'security/py-rsa/Makefile')
-rw-r--r--security/py-rsa/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/security/py-rsa/Makefile b/security/py-rsa/Makefile
index ae5d8e95ca78..c3db3c5c0104 100644
--- a/security/py-rsa/Makefile
+++ b/security/py-rsa/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rsa
-PORTVERSION= 3.1.1
+PORTVERSION= 3.1.2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,10 +12,16 @@ COMMENT= Pure-Python RSA implementation
LICENSE= AL2
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.1.3:${PORTSDIR}/devel/py-asn1
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1>=0.1.3:${PORTSDIR}/devel/py-asn1
+TEST_DEPENDS:= ${PYTHON_PKGNAMEPREFIX}unittest2>0:${PORTSDIR}/devel/py-unittest2 \
+ ${RUN_DEPENDS}
-USE_PYTHON= yes
-USE_PYDISTUTILS=easy_install
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
NO_STAGE= yes
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} run_tests.py
+
.include <bsd.port.mk>